AMD Processors
Decrease font size
Increase font size
Topic Title: RAID 1 REBUILD
Topic Summary:
Created On: 07/01/2008 04:40 AM
Status: Read Only
Linear : Threading : Single : Branch
<< 1 2 3 Previous Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/08/2009 08:01 PM
User is offline View Users Profile Print this message

Author Icon
anglik666
Member

Posts: 55
Joined: 11/04/2008

Could U show us exactly what do U have in RAIDXpert Logical and Physical views ?

-------------------------
#1 - MSI DKA790GX, Phenom II 940BE, 4x1GB Kingston 1066, Sapphire HD 4870 512MB, SB X-F1, 3x WDC SE16 500GB, OCZ 650w
#2 - GA-MA790X-DS4, Phenom X4 9750, 2x 1GB Kingston 533, Sapphire HD 3870 512MB, 1x IBM 160GB, OCZ 650w
 08/09/2009 07:54 AM
User is offline View Users Profile Print this message

Author Icon
CaptnCanary
Junior Member

Posts: 2
Joined: 08/07/2009

I managed to fix my problem and rebuild my Raid array using the solution described above. The biggest problem I had was that I could not work out if I was booting into the Disk assigned to the Raid 1 array or assigned to JBOD. In the end I unplugged each drive individually and tried to boot into each. Only 1 would boot at all and that drive was assigned to Raid 1 in RaidXpert (but was listed as 'Single Disk 1' in BIOS) so I was pretty sure I was booting into the disk needed. So I deleted the JBOD drive in RaidXpert as instructed and sure enough I was able to select rebuild and it was fixed in less than an hour )
 01/10/2010 08:30 PM
User is offline View Users Profile Print this message

Author Icon
sjwoo
Newbie

Posts: 16
Joined: 05/10/2004

Ugh...I have the Biostar TA790GXE running Win 7 Ultimate. I got the dreaded "critical" message again today. I went through the rebuild once -- is there a cure for this? If not, I'm gonna have to return this stupid motherboard.
 07/12/2010 12:44 AM
User is offline View Users Profile Print this message

Author Icon
charlest
Lurker

Posts: 1
Joined: 07/11/2010

I had similar problems to CaptnCanary, in my case on an ASUS M3A78-EM with the latest BIOS 2003. Once it went critical, it became unbootable. I confirmed the boot order was the same as before, and it was booting from the critical RAID and not the corrupted drive in the BIOS, and via manual boot selection with F8.

It turns out once the RAID-1 breaks and the failed drive is no longer assigned to the main array, the BIOS becomes mixed up and the boot order options of RAID Array 1 and RAID Single Drive 1 or something similar are actually labelled in reverse. When you choose to boot from the drive assigned as the Array, the system is unbootable. I noticed when I disconnected the known corrupt disk (which had not failed, it was just corrupted somehow) the PC would boot fine, but as soon as I connected the corrupted drive the system was unbootable. Obviously in this case, I cannot boot with both drives active so I could not initiate the rebuild in Windows.

I assumed the corrupted, unlinked drive was somehow still being seen and used as part of the array and thus causing the problems. So I set the controller back to SATA mode, fully SMART tested the drive and then zeroed it using Seagate Seatools for DOS. But after all of this (it would now be equivalent to a new disk off the shelf), the booting with both drives connected problem persisted. At this point I tried selecting a boot off the blanked drive using F8 (RAID Single Disk vs RAID Array 1) and it booted up fine. This is how I realized the motherboard BIOS (not the RAID BIOS) was mislabelling the drives in its boot selections when the controller was in RAID mode. Now that it had booted normally with both drives active, I ran the RAID Xpert utility and initiated the array rebuild. There were no performance issues--the 1.5TB array rebuild completed in about 3 hours.
 09/28/2010 01:34 PM
User is offline View Users Profile Print this message

Author Icon
Om3r
Lurker

Posts: 4
Joined: 09/28/2010

Hi guys, i had my Raid 1 working fine but 2days ago i had 1 of the HD crashed.. and ive got the critical msg at startup.. I just replaced the hard drive for a new one. What to do now??

Here is what i have in RAIDXpert



Edited: 09/28/2010 at 03:30 PM by Om3r
 09/28/2010 03:41 PM
User is offline View Users Profile Print this message

Author Icon
Om3r
Lurker

Posts: 4
Joined: 09/28/2010

Originally posted by: lll

I wrote this a while back on my own "blog", hope this helps. I apologize if it reads a little strange, it's a direct copy and paste.



Issue: AMD RaidXpert Service gives an Raid 1 (or 5, as reported in other forum) array "error" stating a single disk failure. One of the two drives (or may be more in your case, but if that's the case you are beyond screwed) in the Raid 1 array becomes a JBOD standalone drive, basically detached from the array for whatever reason. The drive is still listed as healthy and SMART scan does not show any issue either. It is simply "assigned as JBOD" under "Logical Drive View" in RaidXpert.



OR, you really have a dead drive, and you have inserted a new drive. But even after you have initialized it, the Rebuild tab is still greyed out.



The "reasonable" procedure, by intuition, since there is no manual, is to start RaidXpert in the browser (username and password by default are both "admin"), go to the "Logical Drive View" and do a "Rebuild". The problem is, the "Rebuild" tab is greyed out and unusable. You can only see the failed array listed as "Critical", one of the two drives (in my case) is still mounted as part of the Raid 1 array, but the other drive is now JBOD. This can also happen if the drive is new. It is simply "assigned" as a JBOD. And the "Rebuild" tab is still greyed out.



You basically cannot rebuild.



This problem has been reported on many forums and no one has provided a step-by-step solution. The AMD Help with the software is inaccurate and unhelpful.



Solution: Make sure that you have boot into the remaining Raid 1 drive and NOT the JBOD drive if the array was your system drive. This can be double-checked by going into the BIOS during POST and you should make sure that in the Boot sequence you are booting through the Raid array. If the array is not your system drive, this precaution is not necessary.



Start RaidXpert in Windows. After you have logged into RaidXpert, click "Logical Drive View" under "AMD RAIDXpert" -> "Logical Drive View". You can check the serial number of the working drive and the "JBOD" drive under Physical Drive View, you will see which drive has been assigned to the array and which one is assigned as JBOD. If you are using the new drive, you should see that its serial number is associated with the JBOD assignment. Make a note of that, and make sure you are not replacing the wrong drive.



Under "Logical Drive View", and to the right of the screen you will see "Delete" as a usable tab. Click on it. Do not worry, nothing will happen yet.



Under the "Delete" tab, you will find check boxes next to each one of your array and JBOD drive. Check the JBOD drive and click "Submit". You will see two warning messages telling you that the data in the JBOD disk will be erased. If this is your new drive, no problem, just hit "Ok". And the drive would disappear from the "Logical Drive View". If this was one of the two system drives, this is your last chance to make sure that this is not the drive you have booted into. If you are sure, hit "Ok", and the drive would disappear from the "Logical Drive View".



Once that's done, the Rebuild tab would appear. You can also see under "Physical Drive View" that this drive is no longer assigned, and is therefore "Spare and free" and can be used for Rebuilding.



Now hit "Rebuild" and the process will begin. And you are set.



Hope this helps.



My system information:



ASUS M3A78-T motherboard with the SB750 (the South Bridge responsible for the RAID)

AMD Phenom II 940 X4 Quad Core

System drive (Raid 1): Western Digital Raptor 150Gb model: WD1500HLFS (two of them)

Scratch disk (for Photoshop) (Raid 0): Hitachi Deskstar 500Gb P7K500 (three of them)



OS: Windows Vista 64-bit



The rest is not relevant to this problem. The array that reported failure was the Raid 1 array.



This tutorial/Standard Operating Procedure was written by Leo Lam © 2009. All rights reserved. No right is granted to Facebook Inc or any other entity for reproduction. But do feel free to seed this or post a link to this.



The tutorial is provided "as is", without warranty of any kind, expressed or implied, including but not limited to the warranties of merchantability, fitness for a particular purpose and noninfringement. In no event shall I be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with me or the use of this tutorial. Use this procedure at your own risk.


Thx man this worked for me
 10/02/2010 08:46 AM
User is offline View Users Profile Print this message

Author Icon
Urich
Lurker

Posts: 1
Joined: 10/02/2010

You have delete JBOD disk and create shedule rebuilder disk.
 11/19/2011 12:06 PM
User is offline View Users Profile Print this message

Author Icon
GangreneROoF
Lurker

Posts: 1
Joined: 11/19/2011

I have to say fellas, I don't see how this thread got a rating of 4 out of 5 stars. I didn't see anything that is going to help this guy out...or that did help him out.
5
The same thing happened to me. My RAID 1 under AMD RAID Xpert is rebuilding as I'm typing this. It's at 6% after about 10 minutes (two 1TB drives).

Here's what happened:
1. My RAID 1 was running perfectly.
2. I installed another BD drive and accidentally unplugged my second HD on my raid from the mobo.
3. When I turned my machine on, it said the RAID 1 was critical.
4. I powered down and plugged the cable back in.
5. The second drive was visible, but was off the RAID.
6. I couldn't find anything like a "rebuild" button in AMD RAIDXpert
7. I came to this forum and found this thread. From reading the entire thing it was clear that no one had found out how to rebuild the RAID within AMD RAIDXpert.
8. I went back into AMD RAIDXpert and selected the Spare Drive View.
9. The second drive was available, so I made it a "spare drive"
10. I then had the option to rebuild my RAID 1 using my second drive.

I sincerely hope this helps. In the time it has taken me to type this, I've gone from 6% on my rebuild to 11%. It looks like I'm out of the woods.
 11/28/2011 08:53 PM
User is offline View Users Profile Print this message

Author Icon
MisterSIR
Lurker

Posts: 18
Joined: 11/28/2011

i never have used RAID, fancy technology... i builtpc's foryears, and seen the "RAID" option under storage controller mode and what have you, just always left it at IDE mode, i suppose RAID would be faster or something?. it always used to give me BSOD,but i suppose that was because it didnt have the drivers installed and all that jazz.

-------------------------
AMD Phenom II X4 955 Black Edition OC@ 4.00GHZ 1.45VCore.
8GB Corsair XMS2
ASUS HD6770 GDDR5 1GB 850/2000/???
ASRock A790GXH/128M
Antec 650W
Seagate barracuda IV SATA-II (AHCI)


^^^ Ze Dragon. ^^^
AMD Processors » AMD Enthusiast Community » General Technology Chat » RAID 1 REBUILD

<< 1 2 3 Previous Last unread
Topic Tools Topic Tools
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information