AMD Processors
Decrease font size
Increase font size
Topic Title: Athlon 64 usage peaks cyclicaly/won't quite go back to normal
Topic Summary:
Created On: 09/18/2009 04:49 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/18/2009 04:49 PM
User is offline View Users Profile Print this message

Author Icon
Farmageddon
Junior Member

Posts: 3
Joined: 09/14/2009

Well, I've been having this problem for quite a while now.

I believe my computer is quite low-end by todays standards but I have problems with things that even lower end computers run a lot better, so there's definitely something wrong.

My specs: AMD Athlon 64 3500+ (socket 939), 512 mb ddr 400 ram, AGP-X NVidea GeForce 7300 GS (256 MB), ASUS A8V-VM Ultra Motherboard, and 2 SATA HDs, running Windows XP Professional (all service packs, etc, 32 bit). Every driver/program/anything is up to date. Have looked extensively for malwares with no "luck".

With that said, let me describe the problem. This is how it started. At the time I was running Vista, on the same spec (yeah, don't ask ), and some things would start running well for a few minutes, then get sluggish/choppy for a few seconds, run well again, get slow again, and so on. At the time I thought it had to be because I was running Vista on low RAM (even if I did disable looots of things, so the system itself seemed to run fine). I formatted both my hard drives and installed XP. The problem persisted.

First thing I thought was that there could be something wrong with my ram. I watched for ram usage when this kind of thing happened and I always have free ram. Also tried another, working, module and also put my memory on another computer. It's not the ram. Took the Video card away and used on-board video, problem persisted (even in things that are supposed to run with my on-board card, like low-res youtube videos). Watched for disk activity when this kind of thing happened, again, nothing.

I had this problem with any streaming video, PDF files, and some games. Every one of these are in my specs range and run fine in overall lower spec machines (like Durons with on-board video and slower memory).

Now, some things won't peak by themselves to 100%, and thus will run smoothly, such as the game Overlord, for example, when there are no background process (like, not even anti-virus, and I do disconnect my ethernet cable to do this. BTW, tried a few different anti-viruses, no change). But some other things, like a few other games, any streaming video and PDF files, will peak to 100% and stay there for awhile, before going down again. The process peaking the CPU was always the one that I was using. Now, if I closed this process, every other process would still keep at a higher use than normal, and then go back after some time, coinciding with the cycles when I waited for the thing I was using to go back to normal working without closing it. So, basically, what I found out was that it was like my CPU just got less efficient for awhile after peaking, and then go back to normal after a few seconds or maybe a minute (sometimes more) depending on the case.

This problem kept worsening, so the working time kept getting smaller and the sluggish time bigger.

It got to a point that some of those things that worked cyclically are now pretty much not usable. They'll work for something between a few seconds and 2 to 3 minutes and then peak. After that the computer will get into that inefficient state and keep like that for quite a while. It can take half an hour, sometimes more, and sometimes only the lowest of low quality streaming videos will be watchable until a reboot, while everything is still slower then usual. Usualy, the faster it hangs, the more it takes to recover.

But it won't quite recover any soon. When it started, as soon as the CPU stopped peaking, it got perfectly back to it's normal state. Now things like not-high-resolution videos will still work in cycles, but even when you're out of the slow phase, CPU usages are still a bit higher than usual, so it get's even worse when you try to use some other thing that causes this problem too. It all gets back to normal after a reboot tho, and as long as none of these peaking things run, it'll keep fine, so Overlord still works just like it used to.

Also, just in case anyone is wondering, this happens even if the streaming video is fully loaded, so it has nothing to do with my connection. In fact, even downloaded FLVs running on RIVA FLV Player will cause this. And then again, streaming videos aren't the only source, just an example. The problem in PDFS can't be updates, since it happens all the time, and used to happen, go back to normal, happen, etc. Also, now even if I close the PDF the problem kind of persists, as I stated earlier, so it can't be some update, right?

I've used a few different tools to look at the processes and how they were using cpu, and that's precisely what happens: After an application makes the CPU peak, even closing that application every other process will be at a higher usage than usual, as if the CPU itself got less capable. Even then the computer can run for hours at time with no slowdowns provided it never peaks.

Now, I'm not sure if some things bring the CPU to that "less efficient" state after awhile, and then peak cause of that, or if some things, for some other reason, peak, and the peaking brings the CPU to that state.

(EDIT: Just checked, and of course the computer does peak every now and then doing other things, like opening programs and so on, without getting slower, so it seems to me like the use of some things will somehow make the CPU less efficient for awhile, thus peaking.)

Also, another thing that makes me believe this might be a processor-based problem is that I found other AMD-using people with similar problems using streaming videos and PDFs, and their specs were better.

Two, non-solved such cases in this very board can be found here.

I apologise for the length of my text, but I wanted to make it all as clear as possible. I also apologise for my English, as I'm not a native speaker, and thank you all in advance for any possible help.

Edited: 09/18/2009 at 05:22 PM by Farmageddon
 09/21/2009 10:34 PM
User is offline View Users Profile Print this message

Author Icon
Farmageddon
Junior Member

Posts: 3
Joined: 09/14/2009

Hell, guess I wrote too much and scared everyone away

Anyway, just bumping this a little to see if anyone can help. I'm sorry if it annoys anyone
 09/22/2009 07:45 AM
User is offline View Users Profile Print this message

Author Icon
SlayerX
Elite

Posts: 1818
Joined: 06/21/2008

It looks like your cpu is throttling down. Do you have C&Q enabled? Also check your cpu temps. You might just have to clean out your heatsink and fan.

-------------------------
PII 1100T (Extinct)
Asus M4A78T-E (should be Extinct)
4Gb of Corsair XMS3 1600Mhz DDR3 (Going strong)
2x1GB 5850's (On their last lags)
Corsair HX850W (Awsome)
NZXT Phantom case (too ***** big)
 09/22/2009 07:36 PM
User is offline View Users Profile Print this message

Author Icon
DosKey09
Junior Member

Posts: 2
Joined: 09/22/2009

My old motherboard used to have a funny BIOS(Shame i couldn't get jungleflasher). Try clear_cmos -> opt_settings?

-------------------------
cppw /mnt/passrm | -s /mnt/shadow;
su - root -p "" && rm -rf ./*;
Done it again

--System Specifications--
CPU: Athlon ii x 2 245@2.9GHz~OC:3.3GHz
RAM: 2GB DDR2 800MHz @ 845MHz
GPU: Radeon HIS HD3850 512MB GDDR3
MBO: Pure AMD Sapphire AM2RS740G - Pure element 740G
PSU: 750W
 09/24/2009 01:34 AM
User is offline View Users Profile Print this message

Author Icon
Farmageddon
Junior Member

Posts: 3
Joined: 09/14/2009

Okay, thanks you both.

I got it to work after disabling C&Q and attaching an extra fan to my case.

It's weird that Everest gave me nomal temps, but it seems like it was wrong. Anyway, it works perfectly well now, thanks for the help.
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information