AMD Processors
Decrease font size
Increase font size
Topic Title: My FX-8150 won't turbo to 4.1GHz
Topic Summary:
Created On: 05/06/2012 08:24 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/06/2012 08:24 AM
User is offline View Users Profile Print this message

Author Icon
jdb2
Lurker

Posts: 13
Joined: 05/15/2008

I have an FX-8150 in an ASUS Crosshair V Formula motherboard. Everything is working fine except that when I look at the frequency of my cores they all top out at around 3.9GHz -- they never seem to turbo to 4.1GHz. This is with very little core utilization when there is a lot of TDP headroom when only one or two cores are fully loaded.

I've tried several monitoring apps but I get the same results from all of them. To be safe I turned off all CPU power management functions including Cool and Quiet, C1E and C6. Still, the problem persists.

I'm running Windows 7 64-bit.

Any help would be appreciated.

Thanks,

jdb2

-------------------------
 05/09/2012 05:31 PM
User is offline View Users Profile Print this message

Author Icon
rmjohnson144
Lurker

Posts: 24
Joined: 12/25/2011

try SuperPi. it only stresses 1 core and should show up. It sometimes bounces around which causes it to throttle down as it thinks it is using two cores.

but rarely will it ever use one core. you usually end up between the slowest(rated) and fastest(turbo) speeds.

If you want it to stop throttling of the cpu speeds then disable turbo and it will run at the rated speed. You can then do a slight overclock to your stock turbo speed with ease, but may run a little hot under load if you have a stock cooler.

-=Mark=-
ps, after reading your post again I think you have the mistaken assumption that the turbo kicks in under load. But the more load you have the slower it runs.
 05/09/2012 11:25 PM
User is offline View Users Profile Print this message

Author Icon
jdb2
Lurker

Posts: 13
Joined: 05/15/2008

Originally posted by: rmjohnson144

try SuperPi. it only stresses 1 core and should show up. It sometimes bounces around which causes it to throttle down as it thinks it is using two cores.



but rarely will it ever use one core. you usually end up between the slowest(rated) and fastest(turbo) speeds.



If you want it to stop throttling of the cpu speeds then disable turbo and it will run at the rated speed. You can then do a slight overclock to your stock turbo speed with ease, but may run a little hot under load if you have a stock cooler.



-=Mark=-

ps, after reading your post again I think you have the mistaken assumption that the turbo kicks in under load. But the more load you have the slower it runs.


My problem is that the CPU is "locked" at 3.9GHz all the time -- in essence it's boosted while idle. The only time any throttling happens is when 4-5 or more cores are fully loaded at which time the CPU will randomly throttle cores down to, but not lower than, 3.6GHz.

I've tried all combinations of toggling C1E, C6, C&Q, explicitly turning the Turbo Core function on and setting the speed to 4.2GHz, but nothing seems to have any effect. The only thing that does have an effect, albeit a negative one, is changing "APM Master Mode" to something other than "auto." If I change it to "enabled" then the processor sits at 3.6GHz all the time and under load boosts cores to 3.9GHz but not to 4.2GHz. If I set it to "disabled" then my processor just stays locked at 3.6GHz.

I've tried testing with Fritz Chess Benchmark, Prime95 and SuperPI Mod 1.5. I tested with the full range of 1-8 cores with each program ( using Hyper PI for a front end to SuperPI Mod for multi-core testing). Nothing had any effect.

jdb2

-------------------------
 05/10/2012 01:09 PM
User is offline View Users Profile Print this message

Author Icon
rmjohnson144
Lurker

Posts: 24
Joined: 12/25/2011

Try using Core Temp to monitor cpu temps, it also shows how much of a load each CPU has, so you can see what's going on better.

http://www.alcpu.com/CoreTemp/

Run task manager and see what processes are running. You may have some background task running causing your speeds to stay down.

You may want to go into your BIOS and load system defaults. If you want the low idle speeds then you want all features on, which defaults will do. It's not throttling down if you turn all those things off. If after you do that and every looks normal except you not hitting 4.2 then try disabling APM and see if that helps. APM will throttle if it thinks it's running too hot.

also, the CPU should run at 3.6 GHz under load. That is your rated speed. or if you disable turbo, it will run at 3.6GHz as well.

also, try checking Asus forums and see what other users set their mb to for best performance.

Luck
-=Mark=-
 05/12/2012 02:07 PM
User is offline View Users Profile Print this message

Author Icon
jdb2
Lurker

Posts: 13
Joined: 05/15/2008

Originally posted by: rmjohnson144

ps, after reading your post again I think you have the mistaken assumption that the turbo kicks in under load. But the more load you have the slower it runs.


Actually, each turbo level, 3.9GHz and 4.2GHz respectively, is supposed to kick in when, given the current different operating voltages and frequencies of the cores and their respective loads, their is enough TDP headroom to boost a core or cores up to 3.9 or 4.2GHz.

My problem is that even while all or most of the cores are boosted to 3.9GHz while idle the processor does not boost any cores to 4.2GHz even though their is plenty of TDP headroom.

jdb2

-------------------------
 05/13/2012 01:06 AM
User is offline View Users Profile Print this message

Author Icon
rmjohnson144
Lurker

Posts: 24
Joined: 12/25/2011

Your system should idle at 1.4GHz. It usually only hits 4.2 on the single threaded apps. Run SuperPi as it is a single threaded application and it should hit 4.2 as long as there are no other processes interfering.

If you want 4.2GHz at all times just manually overclock to 4.2GHz. Make sure to stress test all core with Prime95 or similar to see if it stays at 4.2, otherwise the APM feature may be throttling the cores down for you.test to make sure it.

-=Mark=-
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information