AMD Processors
Decrease font size
Increase font size
Topic Title: Opteron 2000/8000 motherboard compatibility
Topic Summary: Can you use a pair of 2000 series Opteron chips in a quad-socket, 8000-series capable board?
Created On: 01/29/2008 06:51 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/29/2008 06:51 PM
User is offline View Users Profile Print this message

Author Icon
Junior Member

Posts: 1
Joined: 01/29/2008

I'm spec'ing systems based on SuperMicro's A+ motherboards, and I am trying to understand CPU compatibility for the Opteron 2000 and 8000 series chips. I understand that a 2000 chip can only run in a dual-processor configuration, while an 8000 chip can run in a 4-way or 8-way configuration. But given a motherboard that has four (4) sockets and supports 8000-series chips, could I use a pair of 2000-series chips, instead?

The retail price differences between 2000-series and 8000-series chips are quite large. NewEgg (for example) has 2214 (2.2GHz) processors for only $220 each, while the 8214 (also 2.2GHz) is $545. As the chip clock frequencies rise, so does the price gap between the 2000 and 8000 lines.

I would like to purchase a 4-socket motherboard like SuperMicro's 1041M-T2+B (, but the board specifications and manual aren't clear. It says "Supports up to four Quad-Core / Dual-Core AMD Opterontm 8000 Series (Socket F) processor(s)", but what does that actually mean? Does it mean "up to four processors", or does it mean "up to the 8000 Series processor", or both? I'd love to be able to start with a dinky-but-cheap pair of 2000-series chips and eventually upgrade to four 8000 chips, but it doesn't look like it's going to be that easy.

I realize that this isn't a SuperMicro board, but I figured that the chips would be the dominant factor, here. If anyone can shed some light on this issue, I would greatly appreciate it.
 01/31/2008 08:45 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 140
Joined: 11/27/2006

*generally* speaking, it *should* work. Ultimately it is up to SuperMicro to support it, but they are based on the same core.

The parts should work, you can put 8000's into 2000 boards and 2000's into 8000 boards, but you can't get a 2000 to talk to more than one other processor. An easy way to see is to poke around in the BIOS section of their website and see it the BIOS for that system matches the BIOS of a 2000 system. Then all the CPUIDs would match.
 03/07/2009 02:51 PM
User is offline View Users Profile Print this message

Author Icon
Junior Member

Posts: 2
Joined: 03/07/2009

Do you have any experience with this? I have same question and trouble now.

I ask Supermicro marketing if it's work and they say me this.

RE: Question about CPU support on the H8QM3-2 Motheboard
1. Starting configuration with 1(2) x Opteron 2376 (Shangai 45nm
socketF) installed only as single or dual cpu.
[SMC] must be TWO Opteron 2376 install on CPU #1 and #2.
2. Full configuration with 4 x Opteron 8378 (Shangai 45nm socketF) installed as quad cpu.
[SMC] yes

We buy starting configuration and system doesn't start.
Now Supermicro support say me this.
The motherboard can run single or dual processors but the processor must be 8000 series. See the motherboard spec.

I mean, Supermicro is very crazy company. I will try get new bios. (I find that on the board is old bios. It doesn't support Shangai opteron).
After it I will post who has right. Marketing or Support division?
 03/14/2009 04:29 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 12
Joined: 03/11/2009


I'd also like to know about this.

I bought a Tyan s4985 MB and would like to just start out using two 2300 series instead of going for the overpriced 8300 series opterons.

The previous post seems to indicate that the 2376 couldn't boot on that particular Supermicro board?

Would this be because the AGESA code included in the bios is only catering for the 8300 series?

Any news?
 03/16/2009 08:13 PM
User is offline View Users Profile Print this message

Author Icon
Junior Member

Posts: 2
Joined: 03/07/2009

I know more now.
The marketing division have right.
H8QM3-2 Motheboard nonofficially support two of Opteron 2376 (Shangai 45nm socketF)
Trouble was with old bios. Support for Shangai processor are on bios release 3.0 and higher.
Distributor flash the bios with 3.0a version and motherboard works fine.

The supporting division is useless. The trainning monkey on the support email look to specifications and simply say no.
They don't look that there are old bios on the motherboard that doesn't support new processor. (I post the bios version in email to support division)

I don't know if it will be work on the Tyan s4985 MB. Ask marketing or distributor before You buy it. You can save many moneys if You want dual processing configuration with feature upgrade posibility.
 03/17/2009 01:48 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 12
Joined: 03/11/2009

Wewll I already bought the Tyan S4985, got a deal so sweet I couldn't believe it.

Anyway I ordered a pair of 2376's since they have fallen rapidly within the last 2 weeks.

Why I dared this is because I saw that the S4985 was listed using both 2220 and 2350 opterons under some benchmarks in a dual cpu configuration.

So within 3 weeks I will have it up and running hopefully. At least I will be able to tell if it will boot straight out of the box with Shanghai's. I guess not, because I read that they are not supported with the bios version my board currently has (2.02).

I asked a question in the computing reference desk about dual cpu in 4 socket board on wikipedia but answered everything myself so far.

But it seems I can get a really good box up and runnning... very soon if all goes well.'

Prolly have to buy a spare Opteron to update the bios? Since Shanghais are not recognized with bios 2.02....
 06/20/2009 05:24 PM
User is offline View Users Profile Print this message

Author Icon
Junior Member

Posts: 6
Joined: 10/07/2006

I'm glad to see that I'm not the only one who has tried this. I have owned a Tyan S4980 motherboard running with two AMD 2210s installed. I recently purchased two AMD 2376s for that board. Due to a mistake, I'm not using that board now. So I brought a Tyan S4985 (for that same insanely reduced cost others have mentioned) and will now run that board with my 2376s installed.

You can track the progress of my project here at this link:


The problem: Inequity is the root cause of all iniquity.
The solution: The immediate equalization of all knowledge among all beings.
 06/20/2009 05:35 PM
User is offline View Users Profile Print this message

Author Icon
Junior Member

Posts: 6
Joined: 10/07/2006

Tell me what any of you think in comparing a Tyan S4985 to a S4989. The S4989 has a maximum of four-sockets. But the memory footprint is simply insane at 8 per cpu. The board has a maximum capacity of 256GBs. Right now, I have a total of 8 DIMMs for 16GBs. The S4985 has two pci-e x16 slots, while the S4989 only has one. However, the S4989 also has two 64-bit pci-x slots, while the S4985 has only one 32-bit pci slot.

So I'm just wondering which is the better solution. Being that some like me aren't likely going to get 8000 $erie$ processor$ anytime $oon, I'm drawn by the higher memory capacity. That's what got me to buy the Tyan S3992 to start with.

So tell me what you think...

The problem: Inequity is the root cause of all iniquity.
The solution: The immediate equalization of all knowledge among all beings.
 07/22/2009 12:42 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 12
Joined: 03/11/2009

Hi Shingoshi

I couldn't get the s4985 to boot with more than one 2376. I filed a ticket with Tyan support and they responded tha AMD policy was that they will not support the use of 2000 series cpu's in 4 socket mjotherboards.

I was able to run with on cpu but this sort of defeated the purpose of getting such a board.

I bought two 8218 cpu's off of Ebay and I am now running 2 cpu's with 4 cores....

The 2376 have been put on sale.

I tried to mess around with the MP tables an Phoenix Bios editor but did not have success...

Heres a copy of the ticket correspondance:

=== UPDATE 17-06-2009 10:48

Dear I have been discussing this problem with our international team. There is NO support for 2xxx series CPU's on 4-way motherboards. This is a AMD policy and not something that TYAN made up ourselves. There will never be support for 2xxx CPUs on 4-way motherboards.

Best regards,

=== UPDATE StarWatch: 13-06-2009 15:37

=== UPDATE 13-06-2009 15:36

Hi again

Any news :-)

I researched some AMD documents regarding the MP / DP capability of the motherboard, found out that it is decided by the Northbrigde Capability Register (Function 3, Offset E8h).

Reference page 256 of the "BIOS and Kernel Developer's Guide for the AMD Athlontm 64 and
AMD Opterontm Processors"

If the BIOS routine is expecting the MP string in order to initialize the second and following processors would it be possible to change the BIOS MP detect routine so DP capable processors would be enabled such as in my setup?

That would be very welcomed by me :-) Since I then would'nt have to invest a pretty serious amount of money for getting the system up and running..

Another note I flashed BIOS version 207 which in my setup 'bricks' the board and restarts at post code 87 "initializing the chipset ".

So I had to go back to a previous BIOS version.

=== UPDATE StarWatch: 08-06-2009 14:38

=== UPDATE 08-06-2009 14:37

Please stand by, we are discussing this internally at the moment. For now the official statement for 2XXX CPUs on our S4985 is "not supported".

=== UPDATE StarWatch: 07-06-2009 19:43

=== UPDATE 07-06-2009 19:42

Additional information:

I was looking at the bootlogs when installing Ubuntu and got a error msg: no explicit irq entries bios bug using default mp table - this is related to the building of the acpi structures in the BIOS post LED sequence 67 which hangs when I choose the bios option 8259 PIC instead of APIC.

The BSP cannot boot the AP (cpu0 kickingstarting cpu1) blank display comes onscreen and system waits untill you press ctrl alt delte, the keyboard controller apparently still accepts interupts at this time.

=== UPDATE StarWatch: 06-06-2009 17:03

=== UPDATE 06-06-2009 17:03

Some additional information.

When booting into windows 7 (BIOS version S4985-E 2.06F) the BSOD error code is :

(0x00000002, 0xFFFFFA80024A52D0,0xFFFFF8A0000DBE10,0XFFFFFA80024797BC)

The Microsoft explanation to this error is given below - copied from :

(0x00000002, Parameter2, Parameter3, Parameter4):

This error is defined as ACPI root PCI resource failure. To discover what current resources are being used by PCI devices, ACPI must be able to query the CRS descriptor in the ACPI namespace. This error occurs if the BIOS lacks a pointer to the list, or if the list is empty, or if the list contains errors or conflicts.

Further details describing the error is available here:

=== UPDATE StarWatch: 06-06-2009 12:28

=== UPDATE 06-06-2009 12:27

Hi again

Sorry the url part didn´t survive the copy paste of the table in previous post.

Here again for reference:

Thunder n4250QE (S4985) Opteron 2220 SE

Tyan Thunder n425QE (S4985E), AMD Opteron 2350

n4250QE (S4985) AMD Opteron 2222 SE

As reported earlier I was able to install Windows XP 32 bit and Linux 64 bit in different flavours.

After removing cpu1 I have also sucessfully installed Windows 7. This was not possible with both cpu0/1 sockets populated, also tried with cpu0+cpu1 and only fully populated memory in cpu0 no ramm in cpu1´s dimm slots. When both CPU´s are installed the Windows XP and Windows 7 setup gave me a BSOD indicating the computer´s BIOS was not ACPI compliant.

The onboard port 80 LED is displaying a d2 postcode, meaning an unknown interupt error occured. System does POST and load the OS as usual when only CPU0 is installed.

(In the BIOS option when setting the APIC version to the ´old´ PIC mode POSTing stopped at 67 indicating maybe an issue in the initilization of the MP APIC. I don´t know if the bios is setup to search for the _MP_ string and if my configuration reports _DP_ as in Dual processor. Only speculation from my side, as the Intel BIOS dev. docs doesn´t specify that _DP_ is part of the MPS spec.)

System details:
Motherboard Tyan S4985G3NR (Does not say 4985-E anywhere on the PCB)
VRM chips: PULSE PA1315NL 0745-S

RAM : 8 x Kingston KVR667D2S8P5/1G

My next course of action:
1. Get hold of some older generation Opterons that are MP capable.
2. Inject/update the AGESA code 3.3 (Shanghai update) into one of the earlier Bios revisions in order to see if any of the pre 2.06F BIOS versions will recognize the 2nd cpu.

=== UPDATE StarWatch: 05-06-2009 14:14

=== UPDATE 05-06-2009 14:14

Di ,

Would you mind sharing the link with me? This way i have something in my hand that shows that it has been possible. It might be that the Bios actually allowed this in earlier versions. I will need to discuss this symptom with our international team to see how they have made this possible.

=== UPDATE StarWatch: 05-06-2009 13:20

=== UPDATE 05-06-2009 13:19

Hi again

I was actually giving the wrong link, sorry for that. Corrected links follows:

If you look at these links in below table (rightmost columns links to detailed description of the benchmarks) from you can see that 2xxx cpus were tested in a DP configuration. So according to these benchmarks a Dual Processor configuration is supported.

So please consider that the board does support a two cpu configuration. Could it be that the BIOS v. 206 plus 2.06F is assuming a wrong cpu socket topology?

Please if you need more information than the above to be sure please escalate the issue with a TYAN pcb board validation engineer.

Extra details:

I can sucessfully install Linux Debian and Ubuntu and get 1 cpu recognized with all 4 cores enabled. Another issue is installing windows xp professional 32 bit SP2/SP3 - I have to disable ACPI in the windows xp installation program in order to complete installation. Inside windows xp only one processor core is available because the xp installation program will not recognize the bios version used (2.06F / 2.06) as acpi compliant.

Also I can give you much more details about the actual configuration if needed in order to file an issue with the board.

Thunder n4250QE (S4985) Opteron 2220 SE

Tyan Thunder n4250QE (S4985) (AMD Opteron 2220 SE)

Tyan Thunder n4250QE (S4985) Opteron 2220

Tyan Thunder n425QE (S4985E), AMD Opteron 2350

Tyan n4250QE (S4985) AMD Opteron 2222 SE


=== UPDATE StarWatch: 05-06-2009 11:13

=== UPDATE :05-06-2009 11:12

Dear ,

The report you showed me is only talking about one CPU with two cores.
In the benchmark result you will find:
CPU(s) enabled: 2 cores, 1 chip, 2 cores/chip

The S4985 can not work with more than one CPU installed if the CPU is a 2XXX Series.

=== UPDATE StarWatch: 03-06-2009 20:17

=== UPDATE 03-06-2009 20:17

I was under the impression that Dual CPU operation was supported since benchmarks published on


Shows that AMD actually tested and got some results with an older revision of the S4985 motherboard and the dual core Opteron model 2222.

Also the documentation for the AMD Opteron 2376 states that for dual cpu setups only one coherent HT links is necessary.

But one thing I'm not 100% sure about is the board revision it might not be the 4985-e but the older 4985.

The board p/n is:316751900005 07MOA - and the Biosthat the board shipped with was 2.02, I do not know if this indicates that the board is the old revision 4985 (not-E) and that i might have used a bios meant for another version of the board.

Could you tell exactly which model my board is so I can make sure I'm using the correct BIOS.


=== UPDATE StarWatch: 03-06-2009 13:50

=== UPDATE 03-06-2009 13:49

Dear ,

The problem you are seeing is related to the number of Hyper Transport links in the CPU. The S4985 has been designed for the usage of 8xxx Series Opteron CPUs.
The Opteron 8xxx Series CPU have 3 Hyper transport links to communicate to ther CPUs. The 2xxx Series only has 2 Hyper Transport links.

When using 2xxx Series, you will not be able to use more than one CPU on the S4985.
For a full list of supported CPUs, please visit our website at

=== REQUEST SERVICE 03-06-2009 12:16


When the board is posting the board only recognizes the CPU installed in the CPU0 Socket.

I have two Opteron 2376 CPU's installed in the CPU0 & CPU1 socket, none in CPU3/CPU4. Both processors have all their DIMM connectors fully populated. Each have 4 x 1 GB DIMMs DDR2 667Mhz single rank connected.

Bios version is 2.06F - I have tried to switch both ram and processors and both (CPU/RAM) works and will only be recognized in the CPU0 socket /DIMMS.

The Port 80 post code shows 55, indicating that it is trying to enumerate multiple CPU's

Linux installs fine but also only reports one CPU.
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.

Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information