AMD Processors
Decrease font size
Increase font size
Topic Title: Windows will not boot in ACPI multiprocessor mode and other problems PLEASE HELP
Topic Summary:
Created On: 05/17/2007 12:49 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/17/2007 12:49 PM
User is offline View Users Profile Print this message

Author Icon
Deep Blue Dream
Junior Member

Posts: 1
Joined: 05/17/2007

Hi,


I've had my Opteron 170 based computer for about 18 months. I never had serious problems with it before.Recently I had to reinstall my 4 SATA and 3 IDE hard drives.

When I did this Windows XP would start to boot and then restart. I disabled the auto-restart and got a blue screen with "machine check exception". Windows would only boot correctly in safe mode. I reinstalled clean copies of XP on various hard drives and after the installations finished the first boot sequence would always crash at the same place and give the same error.

Here is what Ive already done:

-Made a bootlog in which it loaded all drivers up unti "ACPI MULTIPROCESSOR PC" and that is where is crashed

-changed every BIOS setting I could think of.
-Flashed the BIOS with the newest version
-Disconnected all drives but one and tried to install Windows on that one drive.

-None of these worked at all. I did stumble across a partial solution by forcing XP to install from an IDE drive with no SATA connected *and* forcing it to use "Standard PC" HAL instead of "ACPI Multiprocessor" and then connect the SATA drives later

-Obviously this meant only one of my cores worked in Windows so was slow but it did work for a few hours and then somehow it formatted the drive it was on. I am trying to recover the partition now but in addition to the slowness, some of the IDE drivers wouldn't work in this mode so it isn't very useable.

So I'm really at my wits end trying solve this. I would like to get XP to work with the proper HAL but nothing I've tried works.

thanks for any help...

My Specs
Opteron 170
DFI SLI-DR motherboard.
420W Antech Power Supply
2048MB DDR1 RAM
EVGA 7800GT video card
4 SATA and 3 IDE drive + a IDE DVD burner
Windows XP Pro (32 and 64 bit editions)

Edited: 05/17/2007 at 01:01 PM by Deep Blue Dream
 05/22/2007 04:31 PM
User is offline View Users Profile Print this message

Author Icon
mckennma
Senior Member

Posts: 2989
Joined: 06/01/2005

ACPI needs to be enabled before you install the OS. You need the F6 drivers for your controller to properly use your drives.

-------------------------
Tyan Thunder K8WE
Dual AMD 280 Opterons
8GB NUMA enabled DDR333 2.5-3-3-7 RAM
PCI-X SCSI RAID
http://69.14.190.80
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information