AMD Processors
Decrease font size
Increase font size
Topic Title: DVD burner DMA problems on Tyan Tiger MPX
Topic Summary:
Created On: 02/15/2004 02:42 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/15/2004 02:42 PM
User is offline View Users Profile Print this message

Author Icon
Just Brew It!
Junior Member

Posts: 8
Joined: 10/08/2003

I am having a problem with a TDK Indi 440N CD/DVD burner, when attached to the onboard IDE controller on my Tyan Tiger MPX (S2466N-4M) board. When burning a CD or DVD with Nero, the burn hangs while it is writing the lead-in. The only way to kill Nero is with the Task Manager, and this leaves the DVD drive in a "busy" state, with the disc tray locked. Attempting to do a system shutdown once this has happened results in a complete system hang (no BSOD, it just never shuts down); the only way to recover is with a hard reset.

My OS is Win2K SP4, with the latest IDE busmaster driver (v1.43s, from AMD's web site) installed. The problem may have started around the time I upgraded the motherboard BIOS to v4.06; but I tried flashing back to v4.05 (which I was using previously), and the problem persists.

I've tried diddling the various BIOS settings related to the IDE port (Auto Detect vs. explicitly forcing it to CD-ROM, Enable/Disable 32-bit I/O mode, etc.), with no effect.

The burner has TDK's latest firmware (v1.0A).

Forcing the DVD writer to run in PIO mode by changing the mode in Device Manager seems to prevent the hangs; but this results in slow burns that drag down performance of the entire system. Moving the burner to a Promise PCI IDE controller also seems to prevent the problem... but I'd rather not have an extra controller in there just for the DVD burner, unless absolutely necessary! (It also appears that it is impossible to boot from an optical drive connected to a PCI controller, but this is only a secondary issue... if I need to do an OS repair/reinstall, I can move the drive back to the onboard port...)

The really bizarre thing is that this burner used to work just fine in DMA mode on the onboard IDE port. I can't figure out what has changed that is preventing it from working now.

Any ideas or insights would be appreciated.

 02/16/2004 12:07 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 27
Joined: 01/09/2004

well. did you upgrade tyan bios to v 4.06 yet ??

i am the user of tyan S2466-4m and i put pioneer A-03 (not support DMA) into local IDE port. it work great!

Keep to try!

TYan S2466-4m (AMDchip)
Althon MP 2400+ Dual (0.13)
Transcand 512MB ECC DDR 266 x 2 + Ramos 512MB ECC DDR266 x 1
WD 800JB + WD800JB + WD1200JB
LG 4082 8X +/- DVD writer
Power VR 2 Kyro 32MB AGP
Creative SBlive Value Sound card
3com 3c920 Lan card on board
1394/USB 2.0 NEC combo card
Promise ATA-133 TX2 PCI IDE card x2
Enermax EP 495( 485W )
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.

Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information