AMD Processors
Decrease font size
Increase font size
Topic Title: mobility ati radeon hd 5000 series linux drivers??
Topic Summary:
Created On: 02/26/2010 07:09 PM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/26/2010 07:09 PM
User is offline View Users Profile Print this message

Author Icon
cmcx_linux
Newbie

Posts: 4
Joined: 02/26/2010

Good day all, I don't know if here is the right place to post questions about video driver issues, so I ask for forgivingness in case I miss posted.
I searched the web up and down regarding a useful driver for my mobility radeon hd 5470 video card for linux and I could not find any. The vesa driver on ubuntu does not support the native resolution of the display ( 1366x768) and other drivers throw the no screen error. Right now I managed to force run the latest frglrx driver which works fine except it does not support desktop acceleration ( aiglx turns the screen blank with this driver) and HDMI. More so I have the somewhat annoying picture of AMD unsupported hardware on my right bottom of the screen. For other operations, the driver seems to be rather stable, and works well with movies and fgl_glxgears show a framerate of 700 to 1023 FPS and 3dmark 2001 runs nice and smooth in wine ( around 70FPS overall in benchmarks) .
My driver version is
linux.
2d Version 8.70.3
Catalysr Control Center Version 2.11
RandR Version 1.3
OpenGL Version 3.2.9551
What I want to know if anyone has a clue when this video card will be supported on linux? If are there any beta drivers for it? And more urgent, if there is a way/xorg option to get rid of the AMD Unsupported hardware image on my screen.
Other than that, openCL would be nice, but I think I'd be asking for too much for now.
Thank you for reading, and waiting for replies.

Edited: 02/26/2010 at 07:20 PM by cmcx_linux
 02/26/2010 07:45 PM
User is offline View Users Profile Print this message

Author Icon
PC-GURU -
Lurker

Posts: 8018
Joined: 11/11/2008

my laptop uses the 1 GB 5470 HD. Love the card.here is your driver. Cat 10.2

-------------------------
AMD phenom II 1090T @ 4.23 Ghz custom water cooled
Asrock 890 FX deluxe 3 mother board
4 GB DDR 3 1600 @ 1688 Mhz 7 7 7 24 T1 2688 Mhz NB
2x 1 TB WD Sata III 64 mb cache HDD,s raid 0
2x 5870 HD @ 1015/1300 Asus reference
Dual OS win 7 x64 ultimate & win 7 x32 Ultimate (bench os)
 02/27/2010 11:51 AM
User is offline View Users Profile Print this message

Author Icon
cmcx_linux
Newbie

Posts: 4
Joined: 02/26/2010

Hi,
Well right now that's the driver that I'm using and that isn't quite there yet.
Thank you for the link though.
 02/27/2010 11:52 AM
User is offline View Users Profile Print this message

Author Icon
PC-GURU -
Lurker

Posts: 8018
Joined: 11/11/2008

sorry man, was the best I could find.

I tried lol.

-------------------------
AMD phenom II 1090T @ 4.23 Ghz custom water cooled
Asrock 890 FX deluxe 3 mother board
4 GB DDR 3 1600 @ 1688 Mhz 7 7 7 24 T1 2688 Mhz NB
2x 1 TB WD Sata III 64 mb cache HDD,s raid 0
2x 5870 HD @ 1015/1300 Asus reference
Dual OS win 7 x64 ultimate & win 7 x32 Ultimate (bench os)
 02/27/2010 12:00 PM
User is offline View Users Profile Print this message

Author Icon
cmcx_linux
Newbie

Posts: 4
Joined: 02/26/2010

Ok, I got rid of the watermark with AMD unsupported hardware..
just run this in a root terminal and reset your X server. To get root in ubuntu run sudo su before copy pasting..

DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
done


this is from where I got the info:
http://www.phoronix.com/forums/showthread.php?t=19875
 03/11/2010 10:10 AM
User is offline View Users Profile Print this message

Author Icon
fghelli
Newbie

Posts: 1
Joined: 03/11/2010

How did you manage to force run the latest fglrx driver?
The installation process finishes successfully (the fglrx.so module is correctly loaded and reported by lsmod) but running 'aticonfig --initial -f' gives me 'aticonfig: No supported adapters detected'.

Could you post your xorg.conf?

Thank you!!!
 03/13/2010 11:43 PM
User is offline View Users Profile Print this message

Author Icon
cmcx_linux
Newbie

Posts: 4
Joined: 02/26/2010

Hey, sure, but this is for ubuntu. I haven't tried to fix other distros:
1. open a terminal and type in sudo su to gain root
2. aptitde install module-assistant so you will install all the needed tools to build a kernel driver.
3. download the latest catalyst driver from amd and sh <driver-name>.bin
4. when it's done, from the gui go to hardware manager ( jockey-kde or jockey-gnome, depending on the distro) and activate the proprietary driver extension ( they will appear now).
This will reinstall the drivers with the source from ubuntu, and will activate the apparmor profile for the driver.
5. Since the source got overwritten by the ubuntu stock driver, redo step 3.
6. your driver is now installed, copy paste and run this to strip the watermark:

DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
done

7. modify /etc/X11/xorg.conf to load the new driver . This is fro my asus with a mobility radeon hd with a native resolution of 1355x768 . See xorg.conf on the bottom of the page.
8. On my motherboard, I have some IRQ problems part of the video card, part of the wifi card. I added in /boot/grub/grub.conf to the recently used kernel irqpoll to force the kernel to reroute non working IRQS so I would not end up with memory corruptions. This should go after ro in the kernel... ro quiet splash line

Note: driver does not work with composition enabled.
aticonfig will not generate an xorg.conf file

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "record"
Load "dri2"
Load "dbe"
Load "dri"
# Load "FGL.renamed.libglx"
EndSection

Section "ServerFlags"
Option "Xinerama" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"

#HorizSync 47-49
#VertRefresh 59-61
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"

### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "Rotate" # <str>
#Option "fbdev" # <str>
#Option "debug" # [<bool>]
#Option "UseEDIDFreqs" "FALSE"
#Option "UseEDIDDpi" "FALSE"
#Option "ModeValidation" "NoEdidModes"
Identifier "Card0"
Driver "fglrx"
VendorName "ATI Technologies Inc"
BoardName "Unknown Board"
BusID "PCI:1:0:0"
EndSection

Section "Screen"

#Option "NoVirtualSizeCheck"
#Option "UseEDIDFreqs" "FALSE"
#Option "UseEDIDDpi" "FALSE"
#Option "ModeValidation" "NoEdidModes"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1432x806 1355x768"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection

Edited: 03/13/2010 at 11:55 PM by cmcx_linux
 11/18/2010 03:37 PM
User is offline View Users Profile Print this message

Author Icon
userfall
Lurker

Posts: 1
Joined: 11/18/2010

HP g72 - ubuntu lucid Kernel 2.6.32-25-generic xorg 1.7.5

I have to connect my laptop to lcd monitor over HDMI.
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
Intel graphics work OK but ati does not.
01:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]
01:00.1 Audio device: ATI Technologies Inc Manhattan HDMI Audio [Mobility Radeon HD 5000 Series]
fglrx gives me segmentation fault
 05/08/2011 04:56 PM
User is offline View Users Profile Print this message

Author Icon
sombriks
Lurker

Posts: 2
Joined: 03/29/2011

hello i got it working perfectly on mu openSUSE 11.4 perfectly by generating the package from ati 11.4 (just coincidence) installer.
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information