AMD Processors
Decrease font size
Increase font size
Topic Title: Samba on ubuntu fiesty
Topic Summary: Have it all setup but cannot log in
Created On: 07/21/2007 08:38 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/21/2007 08:38 AM
User is offline View Users Profile Print this message

Author Icon
Stix
Linux Ninja

Posts: 4617
Joined: 03/01/2004

I have setup a server with ubuntu fiesty 7.04 and have updated all. Installed samba and edited its config to look like this

[global]
panic action = /usr/share/samba/panic-action %d
workgroup = "Name"
netbios name = "Server name"
invalid users = root
security = user
wins support = no
log file = /var/log/samba.log
log level = 3
max log size = 1000
syslog = 1
encrypt passwords = true
passdb backend = smbpasswd
socket options = TCP_NODELAY
dns proxy = no
passwd program = /usr/bin/passwd %u
passwd chat =*Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
obey pam restrictions = yes
pam password change = no
null passwords = no

#Share Definitions

[homes]
comment = Home Directories
browseable = yes
writable = yes
security mask = 0700
create mask = 0700

Added a user and password. But when I goto my win xp setup and try to login with
\\(whatever my IP adress is)\homes it does not offer to let me sign into the server I made. The server is connected wirelessly if that makes a difference.

Any help is appreciated.
 07/21/2007 09:39 AM
User is offline View Users Profile Print this message

Author Icon
Mime
Troll Hunter

Posts: 8517
Joined: 10/06/2003

Yeah I've never had much fun dealing with Samba either. But anyway... the "workgroup" setting should be the same as the workgroup that the XP machine is in. If it's not, it won't show up in your "network neighborhood". Once the machine is showing up there, it's eaiser to just browse your network neighborhood as if it were any other folder than fiddle with the direct path, so that's usually what I do. If you can't get it to show up, then you might want to cut your config file down to the bare minimum and then start adding the security options and whatnot back in that you want to have in there. Samba is really picky about file permissions and user access, so it's easy to get snagged on something simple. You can check your config file for errors by typing "testparm" from the command line.

If you've fiddled with the services of the XP machine, then you might have turned off some services which will stop XP from recognizing the share as well. Windows being windows, if that's the problem then it'll just not work and you won't get much in the way of a useful error message.

-------------------------
Containment Breach

Do not meddle in the affairs of archers, for they are subtle and quick to anger.

Edited: 07/21/2007 at 09:42 AM by Mime
 07/21/2007 10:50 AM
User is offline View Users Profile Print this message

Author Icon
Stix
Linux Ninja

Posts: 4617
Joined: 03/01/2004

Checking it out now. Thanks
 07/25/2007 04:37 PM
User is offline View Users Profile Print this message

Author Icon
kccustom
Senior Member

Posts: 453
Joined: 01/25/2004

Try to add a samba user with smbpasswd -a

-------------------------

General discussion on IRC @ irc.dynamix.com / #forums.amd.irc

Edited: 07/25/2007 at 04:40 PM by kccustom
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information