AMD Processors
Decrease font size
Increase font size
Topic Title: Unable to use Radeon HD 6650M, help?
Topic Summary:
Created On: 12/24/2011 04:05 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/24/2011 04:05 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 12/24/2011

Hey. I just recently purchased an Acer Aspire 5560G-SB448 for my girlfriend.
The product page boasted an A8-3500M with an integrated 6620G GPU as well as dedicated Radeon HD 6650M GPU.

The problem is, I cant seem to get any of my games to utilize the Radeon HD 6650M.

They all seem to be using the integrated graphics.

Ive tried going into the BIOS to switch from the integrated GPU to the dedicated, but it only gives me two options, integrated and switchable graphics.

Ive tried using the switchable graphics option through AMD's "Vision ENGINE Catalyst Control Center". Supposedly, you can designate which GPU certain programs use. But unfortunately, this does not seem to work at all. It gives you two options. A program can use "Power Saving" graphics (Integrated GPU) or you can set it to "High Performance" graphics (dedicated Radeon HD card), but even if I set, say, Skyrim to "High Perfomance" graphics, it still uses only the integrated.

Ive even tried updating the BIOS, and every other AMD or Acer drive. No luck.

At this point Im been wondering if maybe I should just disable the integrated graphics through the device manager, but then again, Im not sure if the Radeon HD 6650M card would kick into gear, or if my screen would just go black. I dont want to screw up her laptop a day after recieving it, lol.

This is really disappointing, considering the main reason I purchased this laptop was because of the graphics capabilities, but apparently it turned out to be pretty much bull.

Ive also done three 3DMark 11 tests.
One with settings on "Power Saving" mode.
One with settings on "High Performance" mode.
And one with settings on High Performance, but I also enabled Dual graphics, where the integrated and the discrete are supposed to work together.

Interestingly enough, I got the exact same results on power saving mode and high performance mode, which leaves me to believe that either high performance mode doesnt make a difference at all, or my radeon card just isnt being utilized. My result for these tests was P1217 3DMarks.

But with dual graphics enabled, there was a increase in performance I noticed, although not a huge one. So something must be going on. My results for that test were P1685 3DMarks.

So Im not sure what to make of this.

For instance, I have the same processor as the user in this video (, but I have more ram, and a better discrete graphics card. Yet they can get playable FPS in Skyrim (even while recording with Fraps), but I cant even manage high FPS on low settings.

Can anyone help me out? Thanks.
 12/29/2011 02:00 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 12/29/2011

I just got the same laptop. It does not support crossfire, it supports "switchable graphics" or "Dual Graphics". it has one integrated gpu on the mobo, and one on the chip, the one on the mobo is called a "AMD Radeon 6600M and 6700M Series" when I look under information at the very bottom on the left in Fusion Engine Control Center. The GPU integrated on the chip is well known and is an "AMD Radeon HD 6620G".

To make things use the motherboard integrated GPU, which is only slightly better (other than the 1gb dedicated ram, it's not much better, ddr3 on it instead of most other integrated ati cards which use GDDR5, essentially cutting it's speed in half) you need to install the latest fusion engine control center, and enable dual graphics, and when you do a popup should come up when you start a program asking if you want to configure which GPU to use for that program. Unfortunately this setting is only temporary, and you will have to do it every time you start the program. You can also set it within Fusion Engine Control Center before starting the program, but this can only be set for one program at a time, and again it is temporary. I am learning this is definitely not a gaming laptop, and wondering how I am gonna get my money back... What a piece of crap.

 05/27/2012 02:56 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 05/27/2012

I have exact the same problem with my 6470m,HP Probook 4535s.

First @thebeav111 when you choose high performance for a program it is permanent. On the next start it might be not there but it is activated as high performance. BUT! It don't uses the dedicated graphics card if the game doesn't support DX11 or DX10. That's the main problem. If your game does only support DX9 or OPENGL and you choose high performance for that game or program it dont uses the dedicated graphics card. If you choose power saving it of course uses the IGP too. Check GPU Observer or the AMD System Tool. Only the IGP works, the GPU is off. And yes, it is a bug. In Trinity the problem is solved but AMD ignores the bug on Llano. Im very angry. AMD have to fix it. The feature "AMD SWITCHABLE GRAPHICS" don't work on Llano Laptops

Aside from that problem, im happy with the performance of my laptop in DX11 and DX10 Games. I can play Crysis 2 on High- Extreme with HD Texture Mod and shadows on 0.75 with AVG 26 FPS.

Edited: 05/27/2012 at 03:19 PM by dampflokfreund
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.

Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information