AMD Processors
Decrease font size
Increase font size
Topic Title: FID, VID control not possible on Athlon X2 QL-66
Topic Summary: CPUID reports that FID and VID functionality is not present under Ubuntu
Created On: 07/23/2010 06:38 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/23/2010 06:38 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/23/2010

I have a Compaq 615 notebook with an Athlon X2 QL-66 @ 2.2GHz which seems some kind of Turion CPU. It's getting pretty hot so I'm trying to undervolt it.

The BIOS is very sparse, there are no frequency/voltage options available.

All methods I've tried so far to undervolt under Ubuntu Lucid haven't worked. I think I have pinned down the problem to the following:

Accessing the model-specific registers FIDVID_CTL and FIDVID_STATUS (0xc0010041 and 0xc0010042) results in a failure. Other MSRs can be accessed fine.

In the spec I've read for those registers to work, fid and vid control have to be enabled. This can be read out using CPUID register Fn8000_0007, EAX bits 1,2. Both are disabled, which is also reflected in the line

power management: ts ttp tm stc 100mhzsteps hwpstate

from /proc/cpuinfo missing the entries "vid" and "fid".

Now come the questions:
1) Can I somehow enable the vid/fid functionality?
2) Is it disabled because of the BIOS or because this CPU doesn't support it?
3) Is there another method for undervolting, not using the FIDVID_* registers?

 07/23/2010 03:14 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 07/23/2010

I'm now trying to access the PCI configuration space of the cpu in order to read out the Power Management Mode settings which include a bit called FidVidEn, which hopefully allows me to enable the FIDVID_* registers. I'm still struggling in doing so using Linux. Any advice is welcome. Also the note that this won't work. :/
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.

Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information