AMD Processors
Decrease font size
Increase font size
Topic Title: K7 Athlon - Jabil Kadoka MB - IDE drivers
Topic Summary:
Created On: 08/03/2004 02:58 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/03/2004 02:58 AM
User is offline View Users Profile Print this message

Author Icon
zenbeer
Junior Member

Posts: 1
Joined: 08/03/2004

Having a bit of a pickle here. (oh sure, like we all aren't)

I have an Athlon Slot-A 700Mhz processor on a Kadoka MB that was working just fine until I decided to add a DVD-RW (Liteon 812S) to the system.

I was running 3 hard drives (all Maxtor). A 5GB master, 30GB slave on IDE-1. And a CDROM and 60GB slave on IDE-2.

I was told from the get go that it was a bad Idea to share the CDROM and HD on one channel but it worked for me for a few years.

All my drives were running on DMA cables (80 wire) for all components at this point.

I added the DVD-RW to the system and added a Promise TX2 PCI IDE controller card that was DMA complient. I hooked the 60GB drive to IDE-3 and the DVD-RW to IDE-4. I left the 5GB and 30Gb drives on IDE-1 and the CDROM as a master on IDE-2.

I was experiencing some difficulty burning discs, and decided to upgrade the Kadoka MB Bios to the latest version (which went fine).

I was able to burn some discs.

I then made a series of coaster DVD-R's and decided to check the MB settings.

I saw that on IDE-1 and 2 that the drivers were the default W98SE AMD 756 PCI Bus Master Dual IDE controller versions, with the settings for (dual fifo) which I believe are non-DMA.

I looked around the AMD website for updated IDE drivers and got the AMDdrvpk_130.exe which loaded all the newest drivers without incident. That is, until the IDE drivers were installed. The system continued to reboot over and over and ask me to restart for system settings to take effect, rebooted, and it would ask again, and again, and again to reboot for the system settings to take effect (which they never did).

I finally clicked NO, loaded into windows, and checked device manager. I saw the drivers tried to install but there was a message under the GENERAL tab that said: "This device cannot work properly until you restart your computer (Code 14). To restart you computer now, click Restart Computer (restart computer button)."

These errors appear on hard disc 1 and 2 on IDE 1 and the CDROM on IDE2 - they also appear on the "primary BUS master IDE" and "secondary BUS master IDE"

According to the gateway website this Jabil Kadoka MB specs will handle UDMA 66 devices on the motherboard on the IDE ports.

I have uninstalled these drivers and tried eide_136.exe and eide_143s.exe but with similar or worse results. I'm amazed the system is booting to be honest.

Why wont these drivers load on restart? why does W98Se keep asking to restart?

Help! Help!

The system is up and I can get online, and do basic stuff, but this is not going to work for long - and I do not want to format C: if I can get this resolved.

Post replies, advice, etc. and I'll let you also know what cable configs I've tried, etc. I've already tried removing the promise card and rebooting and it still wont recognize the new AMD drivers on the IDE!!

zen
 08/03/2004 05:51 PM
User is offline View Users Profile Print this message

Author Icon
Charlie22911
Voodoo Programmer

Posts: 3278
Joined: 04/09/2004

try searching the maker of your ide card for an updated driver.

-------------------------
Desktop:
Phenom II x6 1055T @ 4GHz | 4x2GB Patriot DDR3 1600 @ 2000 | 3x AMD Radeon HD6970 Crossfire

Laptop:
Core i7 2960xm @ 4.2Ghz | 4x4GB Kingston DDR3 1866 | 2x GTX 580m SLI OC 725/1450/1500
Statistics
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.



Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information