AMD Processors
Decrease font size
Increase font size
Topic Title: Cant update my drivers, catalyst prgram is bugged, slow frames per second.
Topic Summary: Need help with drivers bug.
Created On: 08/08/2012 03:24 AM
Status: Read Only
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/08/2012 03:24 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 08/08/2012

AMD quad-core processor A8-3500m
AMD radeon HD 6620G, 512MB Graphics system memory
Windows 7 64-bit home premium

So every time i follow the AMD Instructions to uninstall then install my AMD drivers it fails heres how.
--- Causes ---
To install the drivers i simply, install by
clicking install, then custom, select all drivers(about 8+ drivers), then next/install, then restart and it works fine.
Heres how i uninstall then reinstall.
I launch the launch manager.
I click custom.
I click select all, which selects all the drivers( about 8+ drivers/programs)
I click next it uninstalls the drivers.
(In device manager it says I have a missing driver, which makes sense because i just uninstalled a bunch)
It says to restart, i click ok.
After restart i open the launch manager i click install
I click custom, i click select all, (!!!!Only about 4 drivers!!!!)
Then next/install
After install still, in "Device manager" it says unknown device, and update fails to update.

I also cannot access many features in the AMD catalyst program and it is very buggy

I have tried to do this, about 4 times over 6 months, following the tutorial on the AMD site and I still have never had a successful uninstall/reinstall.
(One time I had a 50+ frames per second boost, with NO noticeable errors at all, untill I restarted and the computer started screeching and lagging.)

To fix my computer i have tried, installing the drivers again, no change.
I have tried going to device manager, and clicking update, it gave me a blue screen error.
I was using AMD overdrive one of the times.

If this Message could do better in another section then please, give me a link to it.
112018 users are registered to the AMD Processors forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.

Contact AMD Terms and Conditions ©2007 Advanced Micro Devices, Inc. Privacy Trademark information