Topic Title: Catalyst 12.8 HDMI not working, no HDMI video until reboot.
Topic Summary:
Created On: 08/16/2012 10:26 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/16/2012 10:26 AM
User is offline View Users Profile Print this message

Author Icon
jsantosv
n00b

Posts: 3
Joined: 10/15/2007

Greetings,

Some time ago I had my tv hooked to my PC through an HDMI cable. Everything worked fine, video was perfect and audio worked with zero issues. Some time later I remember upgrading to 12.7, and then both video and audio stopped working. Eventually I got around it by doing this:

1 Connect HDMI cable
2 Reboot PC
3 Click detect screens on display properties (it said nothing detected)
4 Unplug and replug the HDMI cable
5 Click detect screens again (this time the TV was detected)

But, audio still wasn't working. If I clicked the volume notch of the AMD audio volume control, the volume meter moved, as if it was detecting the sound. But nothing came out through the speakers. If I used my XBOX360 with this cable and the same HDMI input on my TV everything worked fine, so I knew it wasn't the cable or my TV.

I started searching for the issue and found many users having similar problems supposedly because the audio driver was being turned off if the TV was not detected, and then it won't turn on properly next time the TV was connected. Ok, cool. No big deal, I'll just use a stereo cable between the audio output of my pc and the input of my TV. I guess it'll be resolved in the next Catalyst version.

12.8 came out yesterday, did a complete reinstall of the drivers (uninstall, driver clean, install) and the same exact issues persist (TV not being recognized until reboot and HDMI audio not working at all).

I'm using a RADEON 5770, Windows 7 Ultimate, 12.8 Catalyst. Everything else with the drivers is working fine, only issues are the described above.

Any help provided will be very appreciated.
Statistics
85772 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.