Topic Title: DVD Copy Protection Issues with new HD6670 Card
Topic Summary: Need help
Created On: 09/02/2012 02:55 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/02/2012 02:55 PM
User is offline View Users Profile Print this message

Author Icon
HollyDontSpend
n00b

Posts: 2
Joined: 09/02/2012

I just installed my new HD6670 2 weeks ago (after my fancier graphics card overheated) and just now tried playing a DVD and it won't play.  Prior to the installation I was able to play DVDs and now I get the message that Windows Media Player is not able to play "because there is a proble with digital copy protection between your DVD drive, decoder, and video card.  Try installing an updated driver for your video card."

I have the most updated drivers for the DVD player (Optiarc DVD RW AD-7203S) and have the most updated drivers for the video card.  Windows Media is the newest version and I'm running on Windows 7 64. 

I downloaded VLC in hopes that maybe that would work to no avail.  Maybe I didn't uninstall my prior graphics card correctly? Maybe I didn't install the new drivers correctly? Anyone have any ideas what I'm missing? Any help would be greatly appreciated. 



Edited: 09/02/2012 at 03:04 PM by HollyDontSpend
 09/02/2012 08:46 PM
User is offline View Users Profile Print this message

Author Icon
Vantharas
Sprite Maker

Posts: 3496
Joined: 03/01/2009

Uninstall your drivers. use driver sweeper to remove any remnants of those video driver files. (if you old card was an nvidia card remove those as well). 

Then reinstall the drivers.  Should fix your issue. 



-------------------------

I5 3570K@4~5.0ghz: Gigabyte GA-Z77X-UD3H:Corsair Hydro H110 :16GB Corsair Vengeance DDR-3 1600: XFX Radeon 7950 @ 1100/1575 : Corsair AX 860 PSU: x1 WD Black 1TB HDD's: 90GB Agility 3: 960GB SSD : Creative Labs X-FI:Corsair 500R Arctic White Edition:3 22inch Monitors Eyefinity @ 5294x 1050 : Alienware Tact-X Keyboard: Razer Naga :Corsair Vengence 1500 Headset: Corsair SP2500 Speakers

 09/03/2012 12:14 AM
User is offline View Users Profile Print this message

Author Icon
HollyDontSpend
n00b

Posts: 2
Joined: 09/02/2012

Grrr! Whimper!!!

I downloaded the sweeper, reinstalled my video card and it still doesn't work.  I went to the website for the CD/DVD ROM and I can't install anything unless it's non OEM.  Bummer.......So, am I better off buying a new one? The thing is, the CDs work just fine, it's just DVDs that aren't working because of the copy protection message.



Edited: 09/03/2012 at 01:16 AM by HollyDontSpend
Statistics
81030 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.