Topic Title: 6770 Not Detected Properly in Device Manager
Topic Summary: Displays as 6700 with poor performance
Created On: 10/30/2012 06:49 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/30/2012 06:49 AM
User is offline View Users Profile Print this message

Author Icon
Utheriz
n00b

Posts: 1
Joined: 10/30/2012

I have a MSI 6770 and was working perfectly.  I bought a new harddrive and installed windows, it was first showing up as 6700 and CCC was unavailable to use.  I tryed to manually upgrade the drivers and it kept saying it was up to date.  It was running perfectly before i got the new harddrive. 

 

When I first booted up the new windows I tried to install the MSI drivers that i had on the cd but was not working, came to the website here and tried to use them and got some weird error with a http address on it as soon as i tried to launch the application, at this point it was just showing up as a Standard VGA Adapter.  I did a windows update, its now showing as a 6700 but im only getting 10fps on minimal settings in Battlefield 3 when before i was getting a steady 60+.  I appreciate any help or advice to this. 

 

MSI 6770 MDIGD5

Windows 7 64bit

AMD APU-3850

MSI a75MA-G55 motherboard

Statistics
84320 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.