Topic Title: XFX Radeon HD 6870, No display
Topic Summary:
Created On: 11/01/2012 11:01 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/01/2012 11:01 AM
User is offline View Users Profile Print this message

Author Icon
paulmccoy
n00b

Posts: 3
Joined: 11/01/2012

With my 6870, when i use a VGA to HDMI cable to connect my monitor to the graphics card I get the message appear on my screen "Check Video Cable", I have changed it in the BIOS so that the graphics is picked up first over the on board, and im just curious to know if anyone knows what the problem would be? 

 

Setup is:

Intel i3

Radeon HD 6870 XFX

600w Corsair PSU

8GB RAM

 

any help would be much appreciated thankyou

 11/01/2012 11:37 AM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 720
Joined: 08/28/2012

Try the following, if you can, as troubleshooting steps that will narrow down the issue:

  • Try a different cable
  • Try connecting a different monitor to the 6870
  • Try connecting the stated monitor on a different computer


-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

 11/01/2012 11:39 AM
User is offline View Users Profile Print this message

Author Icon
paulmccoy
n00b

Posts: 3
Joined: 11/01/2012

Ive tried a different monitor (tv screen) and the monitor i am using was used on my old comp from day one, so the only other thing i can try is the cable on my old pc to check it isnt the cable faulting

 11/01/2012 01:26 PM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 720
Joined: 08/28/2012

So, with everything that you have tried....did the issue stay with the monitor or did the issue stay with the 6870

Have you tried all of the different ports on the 6870?  You are not giving me very much to work with here.



-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

 11/02/2012 09:40 AM
User is offline View Users Profile Print this message

Author Icon
paulmccoy
n00b

Posts: 3
Joined: 11/01/2012

Everytghing I have tried has done the same thing, it realises the graphics card is there it just wont send it to the monitor, im going to buy a VGA to DVI cable to see if that works then let you know

 11/02/2012 01:38 PM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 720
Joined: 08/28/2012

Ok....let's slow down here and take a step backwards.....answer each of the questions below, one item at a time.  You have to provide the information specificly for each question so that WE know what you have done and what is not working specifically.....simply saying "Everything that I've tried" doesn't tell us anything at all.

  • Try the monitor that is not working on a different computer, what is the result (works/doesn't work)?
  • Try a different monitor (that you know works) on the 6870, what is the result (works/doesn't work)?
  • Try that same monitor on each display port on the 6870....does it work on any/all ports, what are the results?


-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

Statistics
87436 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.