Topic Title: Radeon HD5450 not showing in Device Manager
Topic Summary: New Graphics Card problem
Created On: 11/02/2012 12:29 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/02/2012 12:29 PM
User is offline View Users Profile Print this message

Author Icon
Ford Prefect

Posts: 2
Joined: 11/02/2012

Hi Folks,
I recently upgraded to Win 7 but the Win 7 upgrade advisor said "possible" problems with my graphics card (ATI Radeon X1300 Pro) as there was no 64 bit driver for Win 7.

The ATI (AMD) website said this was now a legacy product and no longer supported but 64 bit drivers existed for Vista.

Further investigation lead me to get the Vista drivers for the card.

I also found out that the reason for Windows upgrade advisor giving a warning was that the CCC (ATI Catalyst Control Centre) application used dotNET framework 1 which is not supported on Win 7. The later versions of CCC use dotNET 2 so are ok on Win 7 but keep telling me my driver is incompatible with them.
Anyway, as the X1300Pro was a bit old I decided to buy a new graphics card.

The card is an ATI Radeon HD5450 and is fully compat with Win 7 and has 64 bit drivers.

So I uninstalled the old Graphics card by going to device manager and right-click uninstall.

The uninstall worked OK because my screen immediately went to VGA resolution.

I pulled the power plug, changed over the graphics cards (usual ESD precautions taken) and rebooted.

I loaded the CD that came with the card and ran the set up but half way thru it crashed with a BSOD.

Further investigation shows that the new card is not showing up in Device Manager.

I've checked the main BIOS and it's set to use PEG (PCI Express Graphics) for the video.
I also checked on the AMD website and found later versions (v12.10) of the software and drivers but still got the BSOD halfway thru the install.

I am right in thinking that the card should show in device manager even though the drivers aren't loaded? Possibly with a yellow exclamation mark, yes/no?

So, why should a new card not show in Device Manager?
The spec says its requirements are 1x16 PCIe slot, which I've got. (It's PCIe 1.0, not 2.0 could that be a problem? )

Needs a PSU of 350w and mine is 375w
I don't have another PC around to try it in to make sure it's not a faulty card, so any ideas please.

System Details:


Mobo Intel OCT017 P965 chipset,  BIOS v2.5.3 (latest)

Memory 6GB 2x1GB DELL, 2x2Gb Corsair XMS2

Power Supply id DELL XPS410 rated 375watts

Display is DELL E207WFP connected by DVI

CPU is Intel Core2Duo E6600 2.4GHz

I'm using a 120GB SSD boot drive (OCZ Agility 3)

Data HDD is Western Digital 1TB Sata II

Also have 2 Silicon Image Sata2 controllers (E-SATA) in the PCIe x1 and x4 slots.

HD5450 is in the x16 slot.


Windows 7 Home Premium 64bit

Driver and CCC version 12.10 (10/22/2012)


 11/02/2012 01:04 PM
User is offline View Users Profile Print this message

Author Icon
Master Looter

Posts: 312
Joined: 09/16/2012

The card should be show up in device manager even if the drivers aren't loaded.


Have you tried klicking on "show hidden devices" in device manager


FX 8320// Asus Sabertooth R2.0 // HIS R9 280x //8Gb of 1866Mhz ram, H50 cooling, HX850W psu all stuffed into a NZXT Phantom case.

Was a member of AMD Processer forum since 2008. Last post count 1818.

 11/02/2012 01:52 PM
User is offline View Users Profile Print this message

Author Icon
Forum Moderator

Posts: 738
Joined: 08/28/2012

Did you uninstall all of the old graphics card's software or just the driver?  You might want to try Driver Fusion to make sure that there are no conflicts.

  • Download CCC again (to rule out corruption in the download that you currently have)
  • Download/install Driver Fusion
  • Uninstall CCC completely
  • Reboot into safe mode
  • Right-click Driver Fusion choose "Run as Administrator"
  • Select AMD Graphics
  • Select Analyze
  • Select Clean
  • Reboot when prompted (into your regular OS)
  • Install CCC
  • Reboot 2-3 times before opening CCC up to allow it to complete configuring itself in the background.
  • Re-test


The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

 11/03/2012 04:23 PM
User is offline View Users Profile Print this message

Author Icon
Ford Prefect

Posts: 2
Joined: 11/02/2012

Hi Guys,

Thanks for your interest and your responses.

I did try showing hidden devices but it made no difference.

I did uninstall the old CCC completely, I iuninstalled it using "Add/Remoce" programs first, then I ran Ccleaner on the Registry to get rid of any remnants.

I did try downloading the latest CCC again direct from the AMD website, but still got the blue screen half way through.

Other people are telling me it's because my PCIe x16 slot is v1.0 and not 2.0, is this possible?

The AMD spec just says I need a PCIe x16 slot.


P.S. How do I set up my profile so I get an email when someone posts a reply please?

93380 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.