Topic Title: Sapphire Radeon HD 7770 Card crashing.
Topic Summary: Windows 7/64 bit
Created On: 11/06/2012 04:59 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/06/2012 04:59 PM
User is offline View Users Profile Print this message

Author Icon
Crouton
Peon

Posts: 1
Joined: 11/06/2012

Graphics Card
Saphire Radeon HD 7770
-no overclocking 

AMD Catalyst Driver Version, and Driver History
- Tested the original CD Drvier

-Downloaded the Catalyst Software Suite with .NET 4 Support 12.10 off AMD website.

-Also tried AMD Catalyst Aplication Profiles 12.10 CAP 1

Also tried 

Operating System
-64-bit; Service Pack: 
Version 6.1.7601 Service Pack 1 Build 7601, etc..

- no other OS have been installed previously.

Issue Details
- The driver will crash partially or completely when playing Runescape on either Ogen GL, or Direct X display mode with High settings.  It doesn't crash instantly, but will crash usualy after 5-20 minutes.
-My moniter goes black, and if it recovers from the crash, a message comes up saying Display Driver AMD has crashed and is now recovered. I can't click the message box to see more details as it goes away.  Even if I manage to click it, it goes away.
-Anti-Aliasing OFF
- links to videos or pictures that may demonstrate your issue

Motherboard or System Make & Model
 N-Alvorix-RS880-uATX (Alvorix)

Power Supply

- DYNEX DX PS500W (500W PSU)
-http://www.futureshop.ca/en-CA/product/dynex-500w-atx-pc-power-supply-dx-ps500w/10072461.aspx

Display Device(s) and Connection(s) Used
-Toshiba 24SL410U
- Rocketfish HDMI
Applications and Games

- Runescape

CPU Details
- HP p7-1044t, 2.90Ghz, AMD Phenom II x6 1065T
- no overclocking

Motherboard BIOS Version
-Date American Megatrends Inc. 6.07, 04/05/2011  

-SMBIOS: 2.6


System Memory Type & Amount
- 4x 4GB DDR3

Additional Hardware
- no additional hardware except for PSU

Additional Details
-Norton Anti-Virus (good)
-no hardware check for faults

 11/06/2012 05:25 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7068
Joined: 11/13/2009

Download your drivers here > http://benchmark3d.com/amd-catalyst-12-10-whql

Uninstall your old drivers using your computer control panel / uninstall a program... you will see 'AMD Install Manager' ..Express uninstall all AMD software including the installer. Reboot. Run Driver fusion (free) http://treexy.com/products/driver-fusion  select AMD graphics and delete all it finds. Reboot. Install the latest driver suite for you card including the dotnet4. Reboot. You should be good to go.

Note: All current AMD drivers ( 12.9 and above )require .netframework 4. If you haven't installed it, the CCC panel will not work. You should disable any anti-virus/anti-malware/add blockers/etc before trying to install the drivers.

You might want to read this also > http://forums.amd.com/game/messageview.cfm?catid=444&threadid=161193&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84294 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.