Topic Title: AMD Drivers on Linux error
Topic Summary:
Created On: 11/30/2012 01:37 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/30/2012 01:37 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 11/30/2012

I'm having a lot of problems with installing the ATI Radeon driver for my computer.

I have:

  • ATI Radeon HD7870 graphics card.
  • Linux Mint 14 Nadia installed with Cinnamon x64
  • Two monitors wich I would like to use as one desktop. (haven't made it here yet)

My installation is a fresh installation so I have only tried installing the drivers and here's how I did that: I used this installation guide.

  1. First, since it was a fresh installation, I made sure my installation was up to date (apt-get update, upgrade and dist-upgrade).
  2. Then I installed the prerequisite packages and the ia32-libs as described in the installation guide.
  3. Thirdly, I go to ATI webpage and get the newest stable drivers for my graphics card, 12.10 for 64-bit system.
  4. I run the following installation commands:

    sh ./ --buildpkg Ubuntu
    sudo dpkg -i fglrx*.deb
    sudo amdconfig --initial -f

    That's it. I don't remember any errors, but I don't remember looking for any either.

Now when I restart the comp and log back in, the taskbar for Cinnamon is changed to something that looks more like GNOME. When I try to run the "AMD Catalyst Control Center" from system settings I got a popup saying initialization error. Then I try to run the command for checking version of fglrx and I get this:

    $ fglrxinfo
    Segmentation error

Does anyone recognize this error and can tell me what's wrong?

 12/02/2012 03:50 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 04/18/2011

I haven't played with Cinnamon yet, but I've heard that there are problems with it while running the latest drivers. Also have you got your 32bit Mesa Libraries (e.g.  libgl1-mesa-glx)?

I found it best to just go through the auto-installation rather than building distro specific packages since you're running Linux Mint anyway. I've also noticed you didn't mention what version of drivers you are attempting to use.

93427 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.