Topic Title: Radeon HD 7450: Cannot install drivers
Topic Summary:
Created On: 12/10/2012 10:57 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/10/2012 10:57 PM
User is offline View Users Profile Print this message

Author Icon
tave
Peon

Posts: 5
Joined: 12/10/2012

Link to computer:

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03363686&tmp_track_link=ot_faqs/top_issues/en_us/c03363686/loc:2&cc=us&dlc=en&lc=en&product=5231380

Graphics Card:

AMD Radeon HD 7450

 

AMD Catalyst Driver Version, and Driver History

Windows reports my driver information as:

Driver Provider: Advanced Micro Devices, Inc.

Driver Version: 8.960.11.1000

 

(These were automatically installed by Windows)

 

Operating System
- Windows 7 Home Premium - 64-bit, Service Pack 1

Issue Details
-I cannot install any drivers or the Catalyst control center. When I run the auto driver detect tool, it tells me that it cannot  find my product or OS, but it reports that my graphics hardware is: 0x1002 - 0x677B PCIE and my OS is Windows 7 64-bit.

 

I have tried to remove all drivers and applications (and then run driversweeper to make sure they are gone) and then tried to reinstall, but I get the same issue. I have run everything with admin privelages. 


Motherboard or System Make & Model
- HP h8-1227

http://h10025.www1.hp.com/ewfrf/wc/document?docname=c03363686&tmp_track_link=ot_faqs/top_issues/en_us/c03363686/loc:2&cc=us&dlc=en&lc=en&product=5231380#N68

Power Supply

- 460W

Display Device(s) and Connection(s) Used
- Running dual monitors (one through hdmi->dvi and the other from dvi->vga)... I have tried running just one monitor through dvi and installing drivers (still doesnt work)


CPU Details
- Intel I5-3450 Quad core at 3.1GHz
- No overclocking


System Memory Type & Amount

  • Amount: 8 GB
  • Speed: PC3-12800 MB/sec
  • Type: DDR3-1600

Additional Hardware
- An internal sata 250gb hard drive

 

 

 

 12/11/2012 01:10 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7179
Joined: 11/13/2009

FAQ forum please read > http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162109&enterthread=y

FAQ forum please read > http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 12/11/2012 02:23 AM
User is offline View Users Profile Print this message

Author Icon
tave
Peon

Posts: 5
Joined: 12/10/2012

Catalyst™ Install Manager
Installation Report
12/10/12 23:22:55

Hardware information
 
Name AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x677b
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x2496
Subsystem vendor ID 0x1462
Other hardware
Existing packages
AMD Catalyst Install Manager
AMD APP SDK Runtime
Packages for install
AMD Catalyst Install Manager
Final Status: Success
Version of Item: 8.0.903.0
Size: 20 Mbytes
AMD APP SDK Runtime
Final Status: Success
Version of Item: 10.0.1084.2
Size: 90 Mbytes
HDMI/DP Audio Driver
Final Status: Success
Version of Item: 7.12.0.7708
Size: 1 Mbytes

Other detected devices
 
Manufacturer Advanced Micro Devices, Inc.
Device ID 0xaa98
Vendor ID 0x1002
Class Code 0x040300
Revision ID 0x00
Subsystem ID 0xaa98
Subsystem vendor ID 0x1462


Error messages

 

 

 

 

It still does not install the control centre

 12/11/2012 02:56 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7179
Joined: 11/13/2009

And you still did not uninstall the previous software....

"  Existing packages

AMD Catalyst Install Manager
AMD APP SDK Runtime ""

Why don't you try following the suggestions on how to install new drivers? Step by step. And make sure you have .net framework 4.5. http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y

And download the correct driver suite...do not use 'autodetect and install.'



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *



Edited: 12/11/2012 at 03:10 AM by stumped
 12/11/2012 04:33 AM
User is offline View Users Profile Print this message

Author Icon
tave
Peon

Posts: 5
Joined: 12/10/2012

I did a complete uninstall. I had to run the package twice for everything to install (it installed those first two on the first run)

This is the log from the first run:

 

Catalyst™ Install Manager

Installation Report

12/10/12 23:12:01

 

 

Hardware information 

Name  

Manufacturer Advanced Micro Devices, Inc. 

Device ID 0xaa98 

Vendor ID 0x1002 

Class Code 0x040300 

Revision ID 0x00 

Subsystem ID 0xaa98 

Subsystem vendor ID 0x1462 

Other hardware 

 

Existing packages 

Packages for install

AMD Catalyst Install ManagerFinal Status: Success 

Version of Item: 8.0.891.0 

Size: 20 Mbytes 

AMD APP SDK RuntimeFinal Status: Success 

Version of Item: 10.0.1016.4 

Size: 90 Mbytes 

HDMI/DP Audio DriverFinal Status: Fail 

Version of Item: 6.58.0.6606 

Size: 1 Mbytes 

 

 

Other detected devices 

 

Error messages 

Driver Install: the driver package does not specify a hardware identifier 

 

and then I ran it again so it would install the last package (also, I did not use the auto detect utility, and I have made sure the .net 4.5 is installed and functioning)

I literally did step-by-step

 12/13/2012 07:53 PM
User is offline View Users Profile Print this message

Author Icon
tave
Peon

Posts: 5
Joined: 12/10/2012

bump

 12/16/2012 12:58 AM
User is offline View Users Profile Print this message

Author Icon
tave
Peon

Posts: 5
Joined: 12/10/2012

...double bump

 12/18/2012 02:59 AM
User is offline View Users Profile Print this message

Author Icon
Clanpred
Peon

Posts: 1
Joined: 12/18/2012

I have a similar issue with an ASUS HD 7870 card and the log shows that the display driver fails to install.  I've tried Stumped's advice but no joy.  Please help

 10/08/2013 08:35 PM
User is offline View Users Profile Print this message

Author Icon
SiriusCowKing
Peon

Posts: 1
Joined: 10/08/2013

I have the same problem. My graphic card is amd radeon hd 7450. I followed the steps that stompie gave. I was able to successfully uninstall my driver, but catalyst doesn't seem to detect my video card. Basically when I run the installer it only install the manager and an audio driver which I don't need. At this point, even windows auto installer won't install the driver, I am stuck with widnows generic display driver.

 03/08/2014 07:39 PM
User is offline View Users Profile Print this message

Author Icon
mmoleiro
Peon

Posts: 1
Joined: 02/22/2014

I am also havingthis same issue. I have an HP Pavillion h8-1234 with a Radeon HD 7450 and everything has been fine until about a week ago when I log on to world of warcraft I keep gettng a message saying my display driver isout of date. Ive tried everything here, I have uninstalled the driver and tried to reinstall in safe mode but all i get there is an error message saying it cant find some adapter or controller (I forget - it was a few hours ago). So i rebooted and allowed the PC to download and install the driver on its own and it keeps insalling version 8.960.11.1000 dated 4/25/2012... On the AMD site it lists the newest driver from Dec. 2013 and I have downloaded it and tried installing a dozen or more times. It sometimes even says it went successfully but upon looking in the Device manager at the properties it still says Im running this version from 2012.
I would REALLY appreciate it if someone on here could figure this out!!!  Any ideas???? 

 05/26/2014 10:42 AM
User is offline View Users Profile Print this message

Author Icon
ScottAllen11
Peon

Posts: 1
Joined: 05/26/2014

Same issue for me.  I also have an HP computer.  I notice that the release notes for the 14-4 Catalyst drivers do not list the 7450 as one of the supported video cards. But when you search for Radeon HD 7450, that's the download that comes up.

I don't know if it's because HP lowered the card's power and the drivers don't see it, or because the chipset (equivalent to a 6450 as I understand it) is now unsupported. But my device driver remains dated 2012.

When is AMD going to fix this issue that obviously affects multiple customers? And please, no more troll commends about "follow the directions."

Statistics
84735 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.