Topic Title: Failed to load detection driver
Topic Summary:
Created On: 12/24/2012 06:18 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/24/2012 06:18 PM
User is offline View Users Profile Print this message

Author Icon
dedgar
Peon

Posts: 2
Joined: 12/10/2008

Just installed a 7970 and tried to load drivers. When I try to install them I get a window with 'Failed to load detection driver' and the install fails.

Also, I can only get video output if I start windows in safe mode. If I try any thing else I get a black screen.

 12/25/2012 10:01 AM
User is offline View Users Profile Print this message

Author Icon
dedgar
Peon

Posts: 2
Joined: 12/10/2008

Apparently during the uninstall of the previous drivers a folder was missed. This was causing the black screen.

Using Driver Sweeper that folder was found and removed.

Also, and this took quite some digging on the web to find, you can't load AMD/ATI video drivers while in Safe Mode. This was causing the 'Failed to load detection driver' problem.

Got the folder removed which allowed me to get to Windows desktop. Then was able to load the drivers for the HD7970.

 

 12/25/2012 02:31 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6128
Joined: 11/13/2009

Originally posted by: dedgar Apparently during the uninstall of the previous drivers a folder was missed. This was causing the black screen.

Using Driver Sweeper that folder was found and removed.

Also, and this took quite some digging on the web to find, you can't load AMD/ATI video drivers while in Safe Mode. This was causing the 'Failed to load detection driver' problem.

Got the folder removed which allowed me to get to Windows desktop. Then was able to load the drivers for the HD7970.

 

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

Statistics
81143 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.