Topic Title: Gigabyte HD4850 512MB texture issues
Topic Summary: Texture issues and problems
Created On: 12/27/2012 12:13 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/27/2012 12:13 PM
User is offline View Users Profile Print this message

Author Icon
ALPRAS
Peon

Posts: 5
Joined: 12/27/2012

Hello there.

I recently witch my Nvidia Geforce 8600 GTS for a Gigabyte HD4850. Everything went well, but now I have a major texture issues in some games, like Just Cause 2, Doom 3 BFG and Dead Space. The textures just go crazy, the shadows disappear and appear, everything is flashing. But in Team Fortress 2 nothing happens, its ok. I've completely uninstalled the nvidia drivers and download the most recent drivers for this graphic card, but I don't know what to do... Should I update my BIOS? Should I format the disk and install all over again?

 12/28/2012 06:25 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4001
Joined: 01/27/2008

Well.. a format and install will cure most ailments, but a couple questions first.

What is your PSU? The 4850 needs more power than your old vidcard.

Did you do a driversweep after uninstalling the NV drivers?



-------------------------

#1: Phenom II C2 955BE @ 3.6, Antec Kuhler 920, Gigabyte GA-MA790FX-DS5, Asus 5870/V2, ASUS Xonar D2X, 4 x 1gig OCZ2N1066SR2GK @800, Antec Truepower New 750, Arc Midi, Vistax64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

Statistics
84131 users are registered to the AMD Support and Game forum.
There are currently 10 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.