Topic Title: ATI Radeon 7850 and Windows
Topic Summary: Windows updates keep removing the card from device manager
Created On: 12/31/2012 04:03 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/31/2012 04:03 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 12/31/2012


So a little background. I used to have an ATI 5770 but I decided I wanted an upgrade. I was going to upgrade my graphics card so I upgraded my motherboard, cpu and ram at the same time. After clean installing windows I installed the device drivers for my 64bit Win 7. They worked fine and everything was going well. Windows had some 144 updates to do so I left them to install whilst I played games. (When the card is recognised it can cope with any game)

That night I shut my PC down to install the updates. I woke up next morning and it was using my VGA monitor through my motherboard instead of my through my graphics card. When I tried loading CCC it said no device was present that could be used. I checked device manager and it could only see my onboard Intel one. 

I then re-installed windows again but this time I let it update before installing drivers. It seemed to work. Then last night it had another 14 updates to do. It does them and it no longer recognises my card again! (Last nights updates seemed to be .NET v4 updates which I know the CCC installer uses)

I'm sorry to post such a lenghty explanation, I'm just hoping the more I say the easier it will be to fix. I've checked the card is fitted correctly and it still seems to be. The card when Windows recognises it is fantastic and I should really be getting on at Microsoft (whom I intend to call later) but I decided to ask about here first.


Thanks in advance,


 12/31/2012 06:19 AM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8704
Joined: 11/13/2009

I would check for a bios update from MB supplier as well as going to Intel updates >


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 12/31/2012 06:43 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 12/31/2012

Thanks, I'm trying to do that just now. I can't seem to find BIOS updates for my motherboard from the manufacturers website.

 - I was wondering if it could be a power supple issue. But that doesn't explain why it works before I update windows... 

Edit: Okay - I've updated everything from Intel, which was just a graphics driver for their blasted integrated card. I have found a BIOS update from ASRock but I'm not sure if I should install it or not. Any advice? (Could it not be much simpler?)

Edit2: I used CPU-Z so you can see my Motherboard and CPU:
- The attach files didn't work so I put them elsewhere:

Edited: 12/31/2012 at 07:13 AM by 95Rifles
92896 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.