Topic Title: HDMI Audio from HD 7770
Topic Summary: Can't get audio over HDMI
Created On: 01/02/2013 05:49 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/02/2013 05:49 AM
User is offline View Users Profile Print this message

Author Icon
cyoung75
Peon

Posts: 3
Joined: 01/02/2013

Hi

My nephew got a new PC for christmas and I can't get audio over the HDMI cable on the graphics card. From what I've read on the spec of the card I think it should be capable.

I can't remember the specs off the top of my head and I'm away from his house but he has the Radeon HD 7770 on Windows 8 64 bit OS with 8gb of RAM. If more info is needed I will try to get it later.

The steps I've taken so far to try and resolve this are:

  1. Checking sounds and I can only see realtek (assuming that's the system board) options for audio and it say HDMI isn't plugged in.
  2. Checked the 'view disabled' option and nothing else appears
  3. Downloaded the latest catalyst
  4. Disabled the sound on the system board through the BIOS.

None of the steps above have helped and I'm concerned that something may be wrong with the card.

If I plug in speakers to the system board when the audio is enabled it works fine.

Can anyone help please?

 01/02/2013 10:06 AM
User is offline View Users Profile Print this message

Author Icon
rinkol1
Peon

Posts: 9
Joined: 09/20/2008

You have to select HDMI audio in Windows. Try right clicking on the speaker icon in your task bar and look for "Playback Devices". Alternatively, in the control panel, there is an entry for "manage audio devices". 
 01/02/2013 11:39 AM
User is offline View Users Profile Print this message

Author Icon
cyoung75
Peon

Posts: 3
Joined: 01/02/2013

thanks for that

Is this different from opening sounds and looking at the playback tab for the device. I can only see realtek entries on that list, not AMD

If not, I will have a look when I get home

 01/03/2013 04:37 AM
User is offline View Users Profile Print this message

Author Icon
cyoung75
Peon

Posts: 3
Joined: 01/02/2013

I still can't get this to work.

Does anyone have any other ideas?

Someone else I spoke to said to enable the audio through catalyst 12.10 but I don't know where that option is. Can anyone tell me please?

 01/07/2013 08:38 PM
User is offline View Users Profile Print this message

Author Icon
SubtleOne
Peon

Posts: 7
Joined: 10/27/2008

I have the same problem with a new 7850. I can get audio only by setting it into extended mode, then rebooting. but as soon as I stop viewing anything for a couple of hours the sound can not be recovered until I reboot again.



-------------------------

Intel i5-2500k @ 4.2 GHz
2 x 4GB DDR3 1600Mhz Corsair
Sapphire Radeon 7870

Statistics
81026 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.