Topic Title: Radeon HD7850 Problems.
Topic Summary: Card doesn't work.
Created On: 01/05/2013 04:45 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/05/2013 04:45 AM
User is offline View Users Profile Print this message

Author Icon
Vorka
Peon

Posts: 4
Joined: 01/05/2013

I have an annoying problem and have had it recently for a while I have tried everything and nothing has seemed to work so far. This problem literally makes games unplayable and progress's to worse. When I first start a game it will run fine then slowly marks will start to appear then by the end of an hour or so the game looks like a flashing display of lines.

I have it upgraded up to date for Windows 7 64bit.

 

Here are a few pics to show you what I mean.

The most annoying thing is looking at the screenshots they don't capture 90% of the lines. I have blacked out chat boxes and peoples names for their privacys sake. I have marked the lines I am talking about with red dots.

 

 

My PC Specs are:

CPU: i5 CPU 750 @ 2.67GHz

Card: 7850 HD Series.

Ram: 4.1GB

 

All help is appriciated as this stops me from actually using the card and makes me wish I stuck to my nvidia :/.

 01/05/2013 06:58 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4021
Joined: 01/27/2008

Sounds like a heat problem. Install gpu-z or Afterburner and see what temps the card's sensors are reaching. Afterburner will display the gpu temp onscreen while playing (very handy).



-------------------------

#1: FX-6350, Antec Kuhler 920, MSI 970 Gaming, Asus 5870/V2, ASUS Xonar D2X, 2x4gig GSkill @1866, Antec Truepower New 750, Arc Midi, Win8.1pro x64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 01/05/2013 12:48 PM
User is offline View Users Profile Print this message

Author Icon
Vorka
Peon

Posts: 4
Joined: 01/05/2013

Originally posted by: Hardwood Sounds like a heat problem. Install gpu-z or Afterburner and see what temps the card's sensors are reaching. Afterburner will display the gpu temp onscreen while playing (very handy).

 

 

Just played for a while and temps got to 75 max, is this too high?

 01/06/2013 01:17 AM
User is offline View Users Profile Print this message

Author Icon
OneGun
Peon

Posts: 38
Joined: 11/28/2012

What drivers are you using?Are they just flashing lines that come and go like a flickering effect?

 01/06/2013 02:26 AM
User is offline View Users Profile Print this message

Author Icon
Vorka
Peon

Posts: 4
Joined: 01/05/2013

Originally posted by: OneGun What drivers are you using?Are they just flashing lines that come and go like a flickering effect?

 

 

Flickering lines that slowly get faster and bigger as playing goes on, Starts off perfectly fine then about 30mins~hour later the screens flickering all over.

On properties of the Graphics card it says;

Driver version; 9.10.8.0

Driver date; 02/12/2012

Is that the right one?

 01/06/2013 03:57 AM
User is offline View Users Profile Print this message

Author Icon
OneGun
Peon

Posts: 38
Joined: 11/28/2012

There are alot of flickering issues with these 7series cards and newer drivers.Try installing 12.4.I had alot of problems with artifacts like black triangles and stuff flashing and flickering with my 7850 also.I went to driver download page and downloaded 12.4.I downloaded driversweeper.Then i uninstalled the drivers i was using rebooted into safe mode and used driversweeper to remove all remints of old drivers and then i installed the 12.4 drivers.This work at least i hardly ever see issues anymore.

Give this a shot and let me know if it works.

 02/23/2013 02:12 PM
User is offline View Users Profile Print this message

Author Icon
Vorka
Peon

Posts: 4
Joined: 01/05/2013

Originally posted by: OneGun There are alot of flickering issues with these 7series cards and newer drivers.Try installing 12.4.I had alot of problems with artifacts like black triangles and stuff flashing and flickering with my 7850 also.I went to driver download page and downloaded 12.4.I downloaded driversweeper.Then i uninstalled the drivers i was using rebooted into safe mode and used driversweeper to remove all remints of old drivers and then i installed the 12.4 drivers.This work at least i hardly ever see issues anymore.

 

Give this a shot and let me know if it works.

 

 

 

Problem still carried on and with the neweset 13+ CCC its just a joke. Honestly whoever came up with the idea of making CCC a must have download clearly doesnt own one of these graphic cards. I've gone back to one of the old 10. downloads where you can download the display driver on its own, hopefully it will work.

 02/23/2013 04:42 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12486
Joined: 04/17/2008

Run Memtest86+ to rule out a faulty RAM module. What is your power supply? Does it happen in any other game besides a bad MMO with a poorly modified 6 year old game engine?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
Statistics
85488 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.