Topic Title: Radeon HD 7770 Problems
Topic Summary:
Created On: 01/06/2013 04:28 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/06/2013 04:28 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 01/06/2013

Hey guys, i just recently bought a Sapphire 1gb radeon hd 7770 GDDR5 and a new 600 watt power supply. My computer originally had a radeon hd 6450 and a 280 watt power supply. I have intel i5 2350 as my cpu and i run windows 7. 1 week ago, i got a radeon hd 6570, realizing this does not meet my requirements for gaming, i returned the 6570 and get a 7770 instead with a new power supply. When i first put in the 6570 one week ago. My computer booted fine, i put in the new drivers and it worked. Didnt meet my needs, but it worked. Now after i put in my power supply in with the new graphic card it booted but when i log in i get blue screen. After further investigating. I run in safe mode, delete ALL amd drivers and reboot. After the reboot there is no blue screen. And it runs fine, but when i install the drivers i got from the CD that came with the video card, i am told to reboot. So i do and boom i get blue screen. Then i investigate more and run in safe mode. I delete all drivers again, reboot, and with the computer booting normally i install the drivers online. I even did custom installstion to see what i have installed. I do that reboot and boom i get bsod again. After that i run in safe mode, delete amd drivers again and install them again as well. This time in custom, i install everything except the display adapter driver. I reboot my computer and surprisingly no blue screen. So the problem is on the Display Adapter Driver. When i have the display adapter installed and i run in safe mode, the computer recognizes the graphic card. But when i dont install it and run in normal mode it doesnt recognize the graphics card. So i am in a pickle. I've looked online and seen some suggestions to restart CMOS  but i am not sure what to do. Please help

93069 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.