Topic Title: Radeon HD 6950 - Upgraded to Catalyst 13.1 from 12.11 - Now experiencing Stuttering (No FPS Drops)
Topic Summary:
Created On: 01/31/2013 05:11 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/31/2013 05:11 PM
User is offline View Users Profile Print this message

Author Icon
FireDart
Peon

Posts: 2
Joined: 01/31/2013

 

Hey guys,
I'm hoping you guys can help me out, followed the sticky topic format:

Graphics Card
SAPPHIRE Radeon HD 6950 2GB

AMD Catalyst Driver Version, and Driver History
Previous Version -12.11

Current Version – Was 13.1 now back to 12.11 (For testing)


Operating System
Windows 7 64-bit; Service Pack 1

Issue Details
I just updated my Radeon HD 6950 from Catalyst version 12.11 to 13.1 and now seem to be experience micro-stuttering in every game, however my FPS is fine. I know that 13.1 is aimed more for the 7xxx series so when I found the problem I decided to downgrade back to 12.11 and still experiencing the issue, I'm now back at 13.1.

My definition of "stuttering/micro-stuttering":
Screens seems to jump up and down, a lot, no drop in FPS

The full process (with drivers):
Upgraded from 12.11 to 13.1
Found problem
Uninstalled 13.1 drivers
Rebooted
Install 12.1 drivers
Rebooted
Still having problem
Downgrade again to 12.10 from 12.11 (since 12.11 was a beta drivers for 13.x)
Drivers crashed
Went into safe mode uninstall drivers via Device manager
Upgraded to 12.11 again
Still having problem
Rebooted
Decided to upgrade again to 13.1
Still having problem
Tried re-seating the card (Which would be strange that it happened at the same time yet still worth checking)
Still having problem

I did follow this guide:

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y

and did... for all of the above:

Ran the AMD Uninstall Utility
Rebooted
Ran Drive Sweeper
Rebooted
Installed
Rebooted

Still getting stuttering.

Temps
CPU 35°C ~ 39°C
GPU 42°C ~ 47°C

Perfectly normal and was the same before the driver update.


Motherboard or System Make & Model
ASUS Sabertooth 990FX

Power Supply

Corsair 750W

Display Device(s) and Connection(s) Used
2 Monitors:

ViewSonic HDMI 1080p (Main)

ViewSonic DVI 1080p

Applications and Games

Basically every game however did test the following over and over:

The stuttering is very bad in Far Cry 3 (30 ~ 45 FPS) and even in games like TF2 (Normally get 150+ FPS), funny enough hardly noticeable in BF3 (45 ~ 50 FPS)...

 

I mention the FPS because I find it funny that its stuttering yet I'm still getting solid FPS, no drops.

The issue also stops when I I'm in a menu or use Steam, UPlay or Origin overlay. So I can actually see the game under the overlay, still working, things still happening and it stops shaking...

CPU Details
AMD Phenom II x6 1055T 3.31Ghz

Motherboard BIOS Version
ASUS BIOS 1604

Updated 10/16/2012

Latest Version (Atl east I can't find anything newer)

System Memory Type & Amount
Corsair Vengeance 4GB x 4 (Total of 16GB)

Additional Hardware
2 120GB SSD (Both for boot, each contains an OS, Windows 7 and Ubuntu, however Ubuntu does not matter since this is not an Ubuntu problem but a Windows problem)

1TB Western Digital HDD

3TB Segeate HDD

Additional Details
Scanned with Avast! - Clean

Reseated card – Nothing

 

 

Was trying to get help here yet no luck:

http://linustechtips.com/main/forum/computer-hardware/graphics-cards/71580-radeon-hd-6950-upgraded-to-catalyst-13-1-from-12-11-now-experiencing-stuttering

 

Any help would be greatly appreciated.
-Julian

 02/01/2013 05:35 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

What I would do:

1. Make a separate partition and install a temp OS. Install necessary drivers (12.11) and windows updates and check the problem.

2. Make a separate partition (or format the previous one), install a temp OS, then drivers (13.1), updates and check again.

3. The same thing one more time with 13.2.

Results from this could tell something.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 02/01/2013 04:10 PM
User is offline View Users Profile Print this message

Author Icon
FireDart
Peon

Posts: 2
Joined: 01/31/2013

 

Kinda of the pain in the ass but your right, would help isolate the problem.

If anyone else has a less time consuming solution that would be great, otherwise ill try the above.

 02/01/2013 04:36 PM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 719
Joined: 08/28/2012

Fresh install / fresh drivers of each version would let you know if it is just the newer driver or not.  Wouldn't be the first time that a driver release broke something that worked fine in a previous version....happens all of the time. 



-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

Statistics
86369 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.