Topic Title: Radeon HD 7950 Driver Issues
Topic Summary:
Created On: 02/13/2013 01:59 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/13/2013 01:59 PM
User is offline View Users Profile Print this message

Author Icon
Azrael1701
Peon

Posts: 2
Joined: 02/13/2013

I have recently purchased a Radeon HD 7950, upon plugging it in, everything is fine, however when I install *any* drivers that arent the default microsoft one, the card will crash when windows starts and the machine requires a reboot into safe mode to disable the drivers. I have tried the drivers that came on the CD, the lastest drivers, the beta drivers, plus some older ones too, I also tried both 32 and 64 bit  (even though I have a 64bit OS). I have checked all the usual, the card has plenty of power, the additional power plugs are plugged in, the card is seated properly and the PCI connecter is dust-free. I also tried a full OS reinstall to see if there were any conflicting drivers/applications, but the result was the same.

I also tried to RMA the card to the place of purchase, but they sent it back saying there was nothing wrong with it? (I suspect that they only just plugged it in and didnt install any drivers).

 02/13/2013 02:41 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Maybe incompatibility with the motherboard. I'd try in other computers.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 02/13/2013 02:45 PM
User is offline View Users Profile Print this message

Author Icon
Azrael1701
Peon

Posts: 2
Joined: 02/13/2013

I dont have another machine to try it in unfortunatelly, but I'm not sure thats the issue as it works just with the default driver.

Statistics
88939 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.