Topic Title: 5700 series - just updated - won't start on launch
Topic Summary:
Created On: 02/17/2013 03:39 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/17/2013 03:39 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 02/17/2013

Note: I am not very tech savvy so bear with me:

Hi, I was trying to instal TERA online and could not get it to work, so I tried updating my graphics drivers. I have a ati radeon HD 5700 series, and I updated via the automatic updater. I got a blue screen and I think it never got to finish.

After the automatic reboot my resolution was changed to 800x600 and I am not able to get it back up higher than 1600x1200 which makes my screen look weird.

Also I got an error message that the driver was not working on boot, I tried to reinstall the driver but the automatic updater says that it is already up to date.

I get that somethings amiss with my graphics driver. I tried googling for help but all I get is a maze of graphic driver difficulties that are only loosely related to my problem.

Some information about my system:

Graphics Card

ATI Radeon HD 5700 Series

AMD Catalyst Driver Version, and Driver History

I am not sure where to find this, I tried installing the latest. I bought the computer 2-3 years ago and I think it came with updated drivers. I have updated it about 2-3 times in this period.

Operating System

Windows Home Premium  7 64 bit with service pack 1 installed.

Motherboard or System Make & Model

I don't know, I have installed CPU-Z and on the mainboard page it says the following:

ASUSTeK Computer INC. P7P55-M

Power Supply

I don't know, and I don't  know where to find this.

Display Device(s) and Connection(s) Used

Samsung hdtv monitor  Syncmaster LD220HD, connections used are a HDMI cable and a standard power cable that got delivered with the TV.

Applications and Games

Haven't even tested games yet as it cannot even run windows without a messed up resolution.

CPU Details

Intel Core i7 860 2.80GHz no overclock

Motherboard BIOS Version

American Megatrends Inc. version 0705 from 03/31/2010

System Memory Type & Amount

4096 MB DDR3 don't know the manufacturer.

Additional Hardware

None as far as I know

Additional Details

- I've scanned for virusses like a week ago using Microsoft Security Essentials, I haven't had  viruses or spyware for months.

- Haven't done any other checks as I do not know much of computers.



I hope this is enough information, I will try my best to give more if it is neccesary.


My gratitude in advance,



 02/17/2013 04:35 PM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8744
Joined: 11/13/2009

I think you should try a clean install of your graphics suite. Here is one way to do it >  pay special attention to the .netframeworks requirement for latest drivers and update if necessary before trying to install the new drivers.

Also, don't use the auto-install thing. Follow steps 1-4 and download drivers.


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 02/18/2013 03:37 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 02/17/2013

Woo, the issue seems to be resolved. Thank you!

93059 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.