Topic Title: Video card is tripping
Topic Summary: Monitor detected as CRT or HDTV
Created On: 02/23/2013 02:09 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/23/2013 02:09 AM
User is offline View Users Profile Print this message

Author Icon
Tensors
Peon

Posts: 1
Joined: 02/23/2013

Hi, I just purchased an ASUS Radeon 7950, its gorgeous and I love how it looks, I had a GeForce GTX 9800+ before and I didnt have any problems using my DELL S2440L 1080 monitor (via HDMI to DVI adapter)

 

When I hooked up the monitor to the 7950 (via HDMI) it seemed very VERY VERY ugly, and I have been messing around with it and it looks a lot better now, but still feels odd.

 

If i plug it via VGA it looks better than with HDMI, which shouldnt be happening. I was checking through the CCC's options and I noticed that when plugged through HDMI it detects it as an HDTV and outputs a 1080p signal (it gives me the option between 1080p and 1080i)

 

If I plug it via VGA it detects it as a CRT monitor, which isnt right, its a full HD LCD-LED Pannel and it should be detected as such.

 

And TBH the shadows in DOTA2 look very VERY bad, same with the light effects in CS:GO, my desert eagle looked like one big silver piece with no textures in it. . .

I have already:

 

- Uninstalled monitor drivers from device manager 

- Installed monitor drivers from Dell

- Reinstalled CCC

- defaulted settings for everything

- Used different ports (HDMI - HDMI, HDMI > Adapter > DVI)

(I reseted computer after each of the previous)

 

This is my first radeon card, and from the looks of things it will probably be my last. Im having a horrible experience and the graphics seem worse than my GTX 9800+

 

 02/23/2013 03:33 AM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1326
Joined: 07/13/2009

First, there's no reason why HDMI would provide a superior image than VGA.  The display is digital, so once the analog VGA signal is properly converted and centered, the result is the same.

Second, it's the monitor that's behaving like a TV over HDMI.  That's why the display options use TV terms like 1080p.  You need to set the overscan slider to 0%, and you should also look at the display modes on the monitor's OSD.  Make sure the color is set to RGB, and try all the presets (Movie, Game, Text, etc.) to see what looks best.

Third, when connected via VGA, the image of a CRT just means it's an analog connection.  It's not related to the actual display type.

Sticking with VGA is the simplest way to get good results.  If you want to insist on HDMI, then you need to specify in detail what options you've tried.

 

Statistics
84693 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.