Topic Title: HD 7870 crashing
Topic Summary:
Created On: 03/06/2013 06:30 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/06/2013 06:30 PM
User is offline View Users Profile Print this message

Author Icon
kotd
Peon

Posts: 1
Joined: 03/06/2013

I used a gigabyte HD 7870 for 3 months without problem, then it started having blue screens and then the computer wouldn't boot with the GPU installed. so I RMA'ed that card, got a replacement (same card), and now I'm having a completely different problem.

It works, but causes my computer to crash (no blue screen, just monitors and sound stop working until i hold power off) all the time - more than once an hour if playing games (World of Warcraft, Heroes of Newerth). This is getting ridiculous now that I've tried two of them, and yes I'm sure it's the GPU because this does not happen when I remove it - it also occurs no matter which video card slot I install it in.

Is it incompatible with my mobo or what? I don't understand how the old one worked for 3 months but this one won't work at all, unless the new drivers are all screwy.

 

Catalyst 13.2 beta (tried this after it crashed many times on 13.1, no difference)

Windows 7 x64 Ultimate

Intel Core i7-3770 3.4GHz Quad-Core Processor

ASRock Z77 Extreme4 ATX LGA1155 Motherboard

SeaSonic 620W 80 PLUS Bronze Certified ATX12V / EPS12V Power Supply

Dell ST2421L (HDMI)

Acer AL2216W (DVI)

BIOS American Megatrends inc. p1.40 (5/14/12)

Statistics
86484 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.