Topic Title: Newbie Driver Question
Topic Summary: AMD Radeon HD 7570
Created On: 03/12/2013 11:43 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/12/2013 11:43 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 03/12/2013

Hi all, Sorry for the noob question but I am a new convert to PC gaming.

I recently purchased a PC (HP Envy H8-1450) that came with what I now know is a relative middle of the road (maybe even low end) AMD Radeon HD 7570. After doing a clean install of Windows 8, the 7570 was recongized and it had driver information that listed a date of 9/18/2012 and version number 8.982.10.6000

I came to the AMD site and downloaded the AMD Catalyst Driver Beta 13.2 and after installing, I noticed that the driver information in device manager stayed the same. I assumed it would move up to version 9.012 as listed in the Release Notes. It did not. I have tried reinstalling the driver and even reloading Win 8 but the driver version stays the same.

I then went to the HP site and noticed it had an updated driver called the AMD Unified Graphics Driver update. I downloaded and installed that and now my device manager shows the driver has bumped up to 8.982.10.1800 with a date of 11/14/2012

I would really like to be able to access the improvements and features of the new drivers but I can't seem to get the OS to recognize them. I have tried to force the recognition of the drivers in the C:\AMD\AMD_Catalyst_13.2_Beta7\Packages\Drivers directory but it won't accept them and honestly I am not sure which one I should be pointing it to.

Any suggestions you guys have would be apprecaited.



Edited: 03/13/2013 at 12:20 AM by mosi76
 03/17/2013 02:40 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 9
Joined: 03/11/2013

I've got he same issue with the Radeon HD 7570 and Windows 8.


I posted the details in the Catalyst forum here:


Short version is that the Catalyst Drivers here on the AMD website don't seem to work properly on Windows 8 64-bit. 


A bit of Google searching seems to indicate this is a common issue. No one seems to have any idea how to fix it though as the post has been up nearly a week and so far the only advice has been to try reinstalling.

93084 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.