Topic Title: Microsoft basic render driver with XFX 7970 Ghz
Topic Summary:
Created On: 03/20/2013 09:08 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/20/2013 09:08 PM
User is offline View Users Profile Print this message

Author Icon
Falconary
Peon

Posts: 6
Joined: 12/07/2009

Howdy
I've had a XFX HD 7970 Ghz for about two months and occasionally run some benchmarks to see if everything works as it should.
Yesterday I played Tomb Raider and noticed that the fps went down a bit and it lagged a bit. I ran the Unigine Heaven to compare with previous results, and as I thought, my score had dropped in comparison with previous results. Earlier, it used to be around 1850-1950 points, now its 1700-1730 (running on the same settings of course). Moreover, now the GPU model is Microsoft Basic Render Driver. It was AMD previously ... I have tried uninstalling drivers, erase with drive fusion, go back to the old drivers. Nothing works. 

Suggestions on what I should do? Why does it even say Microsoft basic render driver instead of AMD?

I have windows 8, 64 bit.

 03/21/2013 05:25 AM
User is offline View Users Profile Print this message

Author Icon
goodplay
Cookie Monster

Posts: 411
Joined: 08/21/2011

Was amd driver before or after win 8 instal?.Don't use device manager to update graphics drivers.I installed amd 13.1 straight over the top of ms driver after win 8(oem) instal.



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 

 03/21/2013 12:35 PM
User is offline View Users Profile Print this message

Author Icon
Falconary
Peon

Posts: 6
Joined: 12/07/2009

It was AMD driver with windows 8, i've had Windows since the release. 

 03/22/2013 10:51 PM
User is offline View Users Profile Print this message

Author Icon
goodplay
Cookie Monster

Posts: 411
Joined: 08/21/2011

Tried re-installing 13.1 ?.



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 

 03/23/2013 10:24 PM
User is offline View Users Profile Print this message

Author Icon
rda10002002
Peon

Posts: 6
Joined: 09/05/2012

I am having the same issues on my radeon hd 5750 and i have tried a clean instal of 13.1 and the beta. Any luck on trying to get this to work right?
 03/25/2013 03:04 AM
User is offline View Users Profile Print this message

Author Icon
gamescan
Peon

Posts: 9
Joined: 03/11/2013

The AMD Catalyst Drivers appear to be completely broken under Windows 8.

 

I have a 7570 and WIn 8 64-bit, and the Catalyst Drivers simply refuse to install. No one here seems to have any idea how to troubleshoot it either.

 

http://forums.amd.com/game/messageview.cfm?catid=454&threadid=164682&enterthread=y

 

If you discover any solutions to getting the Catalyst software and Win 8 to play nice, please let me know!

 03/25/2013 06:25 AM
User is offline View Users Profile Print this message

Author Icon
goodplay
Cookie Monster

Posts: 411
Joined: 08/21/2011

@gamescan...So what did amd support have to say re your report(as suggested by "stumped").What did Dell support have to say about your problem.



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 

 03/25/2013 06:28 AM
User is offline View Users Profile Print this message

Author Icon
goodplay
Cookie Monster

Posts: 411
Joined: 08/21/2011

@rda1000....,come on,give some system specs please.(as per **STICKY**). 



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 

Statistics
84829 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.