Topic Title: Hardware Acceleration in Windows 8 Not Working?
Topic Summary:
Created On: 04/16/2013 10:23 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/16/2013 10:23 AM
User is offline View Users Profile Print this message

Author Icon
ls1_01
Peon

Posts: 3
Joined: 04/16/2013

 

There is a problem with hardware acceleration being available and used by applications in Windows 8 64-bit with the latest catalyst drivers.  An example can be seen with PowerDVD 12.  When the catalyst drivers are installed and the KB2795944 critical update from windows update for windows 8 is installed it replaces the radeon drivers (at least partially, read below) and re-installing the catalyst drivers does not fix the problem.  

This can be observed by installing cyberlink's free BD advisor that tests your system to see if it can support blu-ray/3d blu-ray playback.  When KB2795944 is installed with catalyst drivers the advisor will show many failures and say you don't meet the system requirements and show the graphics card as "Microsoft Basic Render Driver".  Uninstalling KB2795944 allows the advisor to pass all tests correctly and shows "AMD Radeon 6450" as the driver with hardware acceleration available.

However, playback within PowerDVD still does not utilize hardware acceleration and CPU usage often goes above 95% even though the advisor passed all tests. The CPU usage by PowerDVD is identical with the Asus 6450 taken out of the machine completely and using on-board Intel HD 3000 graphics to playback the same content and same scenes from a blu-ray disc or 3d blu-ray.  So no offloading to the GPU is occuring.

These problems occur with the latest stable and beta catalyst drivers and might be limited to Windows 8 machines. 

 

Anyone else experienced this?

 04/16/2013 10:48 AM
User is online View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6104
Joined: 11/13/2009

Generally one post is sufficient.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

Statistics
81042 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.