Topic Title: Radeon 5770 - No display from the moment PC is turned on
Topic Summary:
Created On: 05/04/2013 01:04 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/04/2013 01:04 PM
User is offline View Users Profile Print this message

Author Icon
Chanderjeet
Peon

Posts: 2
Joined: 05/04/2013

I've been using it without issues for an year but some days ago my Radeon 5770 went kaput. The screen led is orange and gets no display at all the moment I turn it on. Yes, not even POST (energy screen). The OS boots fine because I can hear the login sound. The on board graphics is working. I can switch to that and I get the display. I checked it on another machine and same thing. No display, not even post screen. What can you guys suggest?

 05/04/2013 03:05 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4851
Joined: 12/27/2008

Originally posted by: Chanderjeet What can you guys suggest?

 

If it's still under warranty, get it replaced. Otherwise throw it in a trash can. (Not literally, it's hazardous waste.)



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 05/04/2013 09:48 PM
User is offline View Users Profile Print this message

Author Icon
Chanderjeet
Peon

Posts: 2
Joined: 05/04/2013

It is still under warranty. Am I glad about that or what.

Statistics
84348 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.