Topic Title: drivers don't seem to work correctly
Topic Summary: very poor fps in games after driver update
Created On: 06/12/2013 08:45 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/12/2013 08:45 AM
User is offline View Users Profile Print this message

Author Icon
criZp
Peon

Posts: 4
Joined: 06/12/2013

hey, after I updated my XFX radeon HD 6870 1gb dual fan card with new drivers, I've got a really poor framerate in games (team fortress 2 and company of heroes 2 beta to be spesific). I used to run a stable 250 fps in tf2, now it's running around 50 fps with the exact same settings, and in coh2 I get around 5 fps in average, with settings set to "auto detect best".

 

Now I've tried the 12.6 and 12.8 drivers, as well as 13.4 and 13.6 beta drivers. full uninstall with driver sweeper/driver fusion in between. surely done over 10 installs now. using gpu-z, I can see that the GPU is working at max when the games are running.

 

 What could be causing this performance loss?

 

edit: oh yea and I'm running vista 64bit with the latest updates and service packs, I don't think any more info about the pc should be needed since everything worked great before the update? so it gotta be something with the drivers

 06/12/2013 01:43 PM
User is offline View Users Profile Print this message

Author Icon
zipsi
Elite

Posts: 1045
Joined: 11/22/2010

Vista is so cute.



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
 06/12/2013 02:04 PM
User is offline View Users Profile Print this message

Author Icon
criZp
Peon

Posts: 4
Joined: 06/12/2013

vista has worked perfect for 4 years, same with the rest of this machine. (apart from the 6870 that is, just got it a year ago)

Statistics
84950 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.