Topic Title: Throttling, Black-Screen, Driver Issues with 7870
Topic Summary:
Created On: 07/04/2013 04:52 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/04/2013 04:52 PM
User is offline View Users Profile Print this message

Author Icon
Rmart003
Peon

Posts: 4
Joined: 07/04/2013

Before I rant about this issue I've been having, for months now, here are my specs:

GPU: Powercolor PCS+ AX7870 2GBD5-2DHPPV GHz Edition (Vortex II Edition)

GPU Factory OC: CoreClock is 1150MHz/Memory Clock is 1250Mhz

Current AMD Catalyst Driver Version: 13.6_beta

Driver History: I have tried almost all drivers from 12.8 and above

Operating System: Windows 8 Home Premium 64-bit

Motherboard: AsRock Z87E-ITX LGA 1150 Intel Z87 MiniITX Motherboard

Motherboard BIOS Version: P1.20

Power Supply: SeaSonic S12II 520 Bronze 520W

Display Devices: Asus VH238H Black 23"

Connections used: VGA to DVI adapter

CPU: Intel Core i5-4670k Haswell 3.4Ghz *NOT OCed*

Memory: HyperX Blu 8GB 240-Pin DDR3 1333 Desktop Memory

Additional Hardware: SSD Boot drive: Samsung SSD 840 Pro Series 128GB, 3 Case fans: 140mm (1) and 92mm (2)...

 

Additional Details: I'm certain that none of my OTHER hardware is defective because I upgraded from a  Phenom II 2x 955 build to this one with the same issue occurring.

Applications and Games: The issue is occurring on any 3d application/game. It happens sometimes in the main menu of any game and other times (like Sniper v2) crashes the application on the main menu. When it comes to settings on the games, I always have them at max, because before the drivers were stable (not anymore), but I dropped them down to a minimum to see if it was the settings but the same issue occurs. I also run every game at 1920 by 1080.

Issue Details: I really don't know what it is exactly but, I think it's the 2d clocks and 3d clocks throttling in-game. My clocks drop from 1150MHz/1250Mhz to 300Mhz/150Mhz and on 13.3 Drivers and below, stay that way unless I restart my system. On 13.6 drivers the drivers seem to flash clock settings back and forth, throttling the clocks that includes temporary 2-5 second black screens in-game until the application crashes.

Other Thoughts: This card gets hot quickly. I had to change the automatic fan speed settings but even at 80% fan speed, this card reaches 70C in less than 5 seconds of running any game.

I've done numerous tweaks with the ULPS settings, AMD Overdrive, changing idle clocks in Overdrive with notepad, swapping Catalyst drivers, and downloading different OC programs that disable 2d clocks with NO results...

If anyone has any kind of attempt to a solution please let me know. Fortunately I still own factory warranty and will RMA if I can't find a solution.

EDIT: I also forgot to mention that I swapped between drivers by either uninstalling drivers manually or using Driver Sweeper (since ATIman 7.0.2 doesn't seem to work for Win8). Also, GPU usage tends to jump around as thottling occurs (pretty self-explanatory but, I thought I'd mention it).

 

 

 07/05/2013 07:09 AM
User is offline View Users Profile Print this message

Author Icon
Rmart003
Peon

Posts: 4
Joined: 07/04/2013

Any reply would be insightful at this point...

 07/08/2013 03:03 PM
User is offline View Users Profile Print this message

Author Icon
Offler
Grinding Levels

Posts: 115
Joined: 06/25/2010

check temperatures of your GPU when you are in menu of Sniper v2. I believe that game menu is running on very very high FPS (500+). 

Such state may cause driver to fail when GPU is overclocked. Try to enable V-sync if possible.



-------------------------

Xeon X3360, Asus Rampage, Gigabyte HD 7970OC, Corsair HX-650

 07/08/2013 05:06 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12663
Joined: 04/17/2008

If it happens in all 3D applications I would suspect it is either a faulty thermal sensor causing the card to throttle, or the card's heatsink not making proper contact with the GPU.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
Statistics
86432 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.