Topic Title: No display after installing the hd 7750
Topic Summary: No display after replacing old gt 210 with the hd 7750
Created On: 07/06/2013 05:29 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/06/2013 05:29 AM
User is offline View Users Profile Print this message

Author Icon
harriz
Peon

Posts: 1
Joined: 07/06/2013

Okay this is wierd...i recently got a new powercolor hd 7750 igb gddr5..

i previously had a nvidia gt 210(sucks....i know )..i first uninstalled the drivers for the 210 by goin into the device manager..and then installed the hd 7750..but now i have no display and the monitor goes into powersaving mode

also tried setting the default fx to pcie in the bios and disabling the integrated one...(btw i cant get into the integrated gfx when the 7750 is plugged in)

tried a different monitor too but no avail..the powersupply is a 450w so thats not a problem too

 im back on the  gt 210 for now

system specs :

OS MS Windows 7 Ultimate 32-bit SP1

CPU
Intel Core i5 @ 2.90GHz

RAM
4.00 GB Single-Channel DDR3 @ 665MHz (9-9-9-24)

Motherboard
Intel Corporation DH61WW (LGA1155 CPU 1)

Graphics
Generic Non-PnP Monitor (800x600@1Hz)
14MB Standard VGA Graphics Adapter (MSI)

Hard Drives
488GB Hitachi Hitachi HDS721050DLE630 ATA Device (SATA) 34 °C

Optical Drives
TSSTcorp CDDVDW SH-224BB ATA Device

 

PS : im really looked forward to playing Bioshock infinite and dishonored on this as i hv 4 days off from college..pls help

 07/06/2013 10:44 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7168
Joined: 11/13/2009

What brand power supply? You might try a clean install of the drivers, but when using the Driver sweeper, delete all Nvidia graphics as well as any AMD graphics. Pay special attention to the netframeworks requirements for the AMD card.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84648 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.