Topic Title: No Display With A 7870 Dual-X
Topic Summary:
Created On: 07/17/2013 08:55 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/17/2013 08:55 AM
User is offline View Users Profile Print this message

Author Icon
CrazyBoy494
Peon

Posts: 2
Joined: 07/17/2013

Hello, i'm new here so sorry if i post this in the wrong section.

A few weeks ago i built my own PC but the video card seems to not giving any display output.

My specs are :

Intel i5 3570;

Radeon HD 7870 Dual-X Edition;

600W Corsair Builder Series PSU;

8GB of RAM (4x2);

ASRock Z77 Pro3 MoBo.

 I'm currently using Windows 7 x64 Ultimate and the onboard card seems to be working without any problem at all.

I made sure :

The GPU is getting power (The fans spin always at normal speed);

Disabled onboard graphics card and made PCIe as primary;

The drivers are installed.

I'm using a DVI-I DVI to VGA Adapter because my monitor does not have a  DVI connection;

Any ideas on how to make it work?

 07/17/2013 09:31 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1340
Joined: 07/13/2009

Try the other DVI port.  You're probably plugged into a DVI-D port.

 07/18/2013 08:43 AM
User is offline View Users Profile Print this message

Author Icon
CrazyBoy494
Peon

Posts: 2
Joined: 07/17/2013

I've checked multiple times, it's in the DVI-I port, i don't even have the DVI-D adapter.

 07/20/2013 12:44 PM
User is offline View Users Profile Print this message

Author Icon
RobRocksRocks
Peon

Posts: 1
Joined: 07/20/2013

I am having a similar problem. My hardware is a little different but similar.

Statistics
84844 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.