Topic Title: Dual monitor problem, 2nd monitor screen is green
Topic Summary:
Created On: 07/26/2013 10:41 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/26/2013 10:41 AM
User is offline View Users Profile Print this message

Author Icon
EL34
Peon

Posts: 10
Joined: 07/26/2013

I just added a 2nd lcd monitor to my Windows 7 home premium 64 bit system
My graphics card is a AMD Radeon HD6670 and I just installed the latest driver for this card from the AMD site

The HD6670 has 3 ports out - DVI, VGA and HDMI
Monitor #1 is plugged into the DVI port - This is my main monitor
Monitor #2 is plugged into the VGA port

I set up dual display in W7 control panel and it works fine except that monitor #2 has this green tint. A really bad green tint.

I have tried two different VGA cables and two different monitors.
The green tint stays with monitor #2 so it's coming from the video card 

Doing a google search I found lots of results of other people having the same issue with dual displays.
Some pople say the 2nd monitor is yellow, some say it's green. 
Not just AMD cards, all kinds of cards, many different cards and manufacturers.

Note that monitor #2 color is perfect when used as monitor #1 so it is not the monitor or the color settings in the monitor
I cannot change the colors on just one monitor in the W7 display control panel., there is not an option for that that I can see.

I have not found a solution in my searches yet.
I am hoping someone here can help.

Thanks

Here's a couple pics of the displays sitting side by side that show how bad the green tint is on monitor #2



Edited: 07/27/2013 at 11:53 AM by EL34
 07/27/2013 11:47 AM
User is offline View Users Profile Print this message

Author Icon
EL34
Peon

Posts: 10
Joined: 07/26/2013

Solved, sort of

The 2nd monitor was plugged in the VGA port on the video card and this is the monitor that was really green in the picture above.

Adjusting the VGA port colors in catalyst could not remove the green.

I switched to the HDMI port on the video card and used a HDMI to DVI adapter on the monitor because I do not have a HDMI port on the monitor

After starting catalyst center and detecting the monitor, the color was normal.

So the problem was the VGA port

So I will continue to use the HDMI port on the video card and not the VGA port.

Statistics
84708 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.