Topic Title: Awaiting Textures on Black Ops 2
Topic Summary: Slow Load on the Map Startup
Created On: 07/28/2013 04:44 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/28/2013 04:44 PM
User is offline View Users Profile Print this message

Author Icon
Tence
Peon

Posts: 1
Joined: 07/28/2013

Hello, this is a REALLY common problem for the Radeon users, and I've been searching for a fix for a long time now. Here's the problem.

I own a Radeon 7770, and the performance of it is the way it supposed to be, I hope. Atleast it runs every game fine, but there's just one problem, only found on Black Ops 2 that is beyond annoying. Everytime the map is loading, it freezes for about 30 seconds on 'Awaiting Textures' and the whole screen freezes, but then it goes on. Thing is, I searched around the forums for a while now, and it turns out only Radeon users have this probrel, and there's alot of people I know who also experience this.

I wanted to ask, if there's an actual fix for this, or is it something I have to live with?

 07/28/2013 04:56 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7218
Joined: 11/13/2009

Originally posted by: Tence   Thing is, I searched around the forums for a while now, and it turns out only Radeon users have this probrel, and there's alot of people I know who also experience this.

I wanted to ask, if there's an actual fix for this, or is it something I have to live with?

This is just not true. I find it hard to believe you did much searching at all. The Activision forum is full of posts like this...with AMD and Nvidia cards. It seems the last BO2 changed everything...according to the posts. 

extra long loading times in last few days.

 

My system specs are pretty high... so went from near instantaneous loading times to taking an extra 5 to 10 seconds to load textures etc, even when the content is already in RAM.....

 

FYI:
Intel i7 3820 at 4.37GHz

Vertex 4 512GB SSD (os + game installed on this)

16GB RAM-- 1666MHz

GTX 580

 

There is NO reason for this game to take any real time at all to load each map and it now seems to take a while to load every round....

I'll try updating to latest Nvidia drivers when home tonight... shouldn't need to however.

  • Egonjaw Newbie 48 posts since
    Dec 25, 2012
    Currently Being Moderated

    Yeah, same thing, my specs are far above recommended, none of my hardware is nowhere even near loaded, at best of times they work at 30% capacity for this game.

    My drivers are up to date, System Mechanic always maintains it free of clutter/registry maintenance/HDD defragments and other things that usually slows down PC's.

    PC itself works smooth as butter, always has since i built it, and it was until the LAST patch of this game...

    It's nothing on my end and never has been, all went bust since last update, so dunno what to do.

    It went from 3-4s loading time to 10-15s, it's a big jump....

  • RediKnight Newbie 21 posts since
    Dec 23, 2012
    Currently Being Moderated

    I have the same problem amd fx4100 cpu, 7850 gfx and 4gb ddr3 ram the problem is that they think they have patched this problem im a previous patch patch notes say something like fixed; long loading times for amd hardware but it wasnt fixed

  • RediKnight Newbie 21 posts since
    Dec 23, 2012
    Currently Being Moderated

    I have the same problem amd fx4100 cpu, 7850 gfx and 4gb ddr3 ram the problem is that they think they have patched this problem im a previous patch patch notes say something like fixed; long loading times for amd hardware but it wasnt fixed

    http://www.callofduty.com/thread/200588818



  • -------------------------

    Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


     


     * A clear conscience is usually a sign of bad memory *



    Edited: 07/28/2013 at 05:56 PM by stumped
     07/28/2013 06:38 PM
    User is offline View Users Profile Print this message

    Author Icon
    Practikill
    Grinding Levels

    Posts: 104
    Joined: 08/07/2009

    With my 6870 1 gig I spend most of the time (20 seconds or so) "awaiting gamestate". Then "awaiting players" for about 3 seconds, then the "awaiting textures" only lasts at most 5-10 seconds.

    Not sure what your problem is, perhaps you have something else hogging your VRAM. 



    -------------------------
    Statistics
    84866 users are registered to the AMD Support and Game forum.
    There are currently 2 users logged in.

    FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.