Topic Title: What's wrong with my new HD 7850
Topic Summary: Fuzzy screen, underpowered GPU
Created On: 08/15/2013 07:57 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/15/2013 07:57 AM
User is offline View Users Profile Print this message

Author Icon
kLN94
Peon

Posts: 2
Joined: 08/15/2013

Hi, i've recently been having some problems with my new HD 7850, I get a fuzzy screen when gaming when I have Vsync turned off. When Vsync is turned on, it goes back to normal. I thought buying a VGA to DVI cable would fix the problem but it didn't. Could it possibly be caused by my PSU? I have a very old PSU, the max Watts is 300. But on the 7850 box, it says minimum required is 500w. I went into CCC and realized the GPU clock was set to 300MHz, even when running a game. The memory clock is set to 150Mhz, but the stock speed is 1200MHz, could this possibly be caused by my weak PSU?

My specs:

Computer type PC/Desktop 
System Manufacturer/Model Number Custom Build 
OS Windows 7 Ultimate 64bit 
CPU AMD FX-4 4100 Black Edition 4 Core 3.6Ghz Socket AM3+ 8MB 
Motherboard GA-78LMT-USB3 (rev. 4.1) 
Memory Corsair 8GB DDR3 1600MHz Vengeance Memory 
Graphics Card Sapphire Radeon HD 7850 
Screen Resolution 1680 x 1050 
Mouse Logitech MX518 & Logitech G400 
PSU ACE 400W Grey PSU 12cm Fan SATA 20+4pin 
Case Coolermaster Elite 430 
Cooling 5 case fans 
Hard Drives 500GB 
Antivirus Windows Security Essentials 
Browser Chrome 

Thanks

 08/15/2013 08:54 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12203
Joined: 04/17/2008

Yes that is A problem, you do not need to game anymore until you replace it. Recommend a SeaSonic or Enermax made 550w unit, preferably 80 Plus Gold or Platinum, for optimal efficiency and so you won't have to replace it in the long term.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 08/15/2013 10:44 AM
User is offline View Users Profile Print this message

Author Icon
Slayerx
Button Masher

Posts: 262
Joined: 09/16/2012

I agree with B_Z in that your psu is way under powered and you should't put a lot of stress on it if it fails it could take your new 7850 with it.



-------------------------

FX 8320// Asus Sabertooth R2.0 // HIS R9 280x //8Gb of 1866Mhz ram, H50 cooling, HX850W psu all stuffed into a NZXT Phantom case.


Was a member of AMD Processer forum since 2008. Last post count 1818.

 08/15/2013 11:58 AM
User is offline View Users Profile Print this message

Author Icon
QB the Slayer
Master Looter

Posts: 322
Joined: 11/27/2012

Good lord....  you are lucky you haven't killed your system already.  Turn the computer off NOW and go get a PSU.

 

QB



-------------------------

The MONSTER HTPC:

CPU: AMD FX-8350.||.Cooler: Corsair H80i
MB: Gigabyte 990FXA-UD7.||.RAM: 8 GB Mushkin Blackline DDR3 2000MHz (7-10-8-27-1T)
Case: CoolerMaster HAF 932.||.PSU: Corsair HX750
GPU:Asus R9 270X DirectCU II TOP.||.Audio: Creative X-Fi Titanium Fatal1ty Pro w/ Logitech Z-5300e (5.1, 280W-RMS)
System Drive: 2xSamsung 840 Pro 128GB RAID0.||.Working Drive: 2xMushkin Chronos 60GB RAID0

Statistics
84156 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.