Topic Title: 7970 GHz Edition Causing Lock-ups and Crashes
Topic Summary: Is there any fix for me to use?
Created On: 09/09/2013 10:29 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/09/2013 10:29 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 09/09/2013

I'll start off by listing my specs:

2x 7970 GHz Edition in CrossfireX (note: this is not a specific CrossfireX issue, rather, it happens regardless of CrossfireX being enabled or not)

AMD FX 8350 (not overclocked)


3TB of total HDD space (split between three HDDs)

1 120GB SSD (Samsung 840 Pro, use it to boot my OS)

Cosmos II case with a LOT of fans

1000 watt PSU

Asus Sabertooth 990fx motherboard

Now that the specs are out of the way, I'll try to keep the explanation of my issues to being as short as possible.

I first started experiencing these issues while playing Crysis 2 maxed out on my 1080p Plasma TV. I tried fixing this by hooking it up to my 1080p monitor, but it still gave me issues. Crysis 2 gave me these issues:

Textures failing to load

Fuzzy textures in indoor areas after an hour of gameplay

Now, Crysis 2 didn't fully crash on me yet, but its succesor, Crysis 3, gave these:

Crash with full lock-up of system (causing me to have to manually reboot my PC)

Random and inexplicable FPS drops no matter if it was indoors or outdoors

Now when playing Battlefield 3, I get these:

Crash with full-lock up of system (same as with Crysis 3)

Sound glitching out shortly before fully crashing

Now, Windows 8 does NOT give me an error log to go on with, so I am at a loss as to what is going on. Now, I DID try installing Windows 7 for a bit, and it STILL happened. I have tried everything to fix this CPU (was with an Intel Core i7 3770k previously), new motherobard (Had an Asrock before), new PSU (had a 800watt Corsair Gold), new SSD, new case (had a Coolermaster CM Storm Trooper before), and so forth. In fact, this issue has replicated itself in other cards from different brands as well. Before this, I had a 580 which died only due to user error (overclocking it), after that I had a 590 that inexplicably stopped being detected by my reciever, then after that I had two 680s which also gave me the same exact issues, just worse. 


I am just at a loss as to what could be causing this. I ran memtest for two plus passes, and nothing really changed, I kept having the same issues, regardless of what I did. 

I hope you guys can help me find a solution, as, really, I cannot state it enough just how frustrating this has all been. (Yes I even tried reinstalling Direct X through Microsoft's fixer program, and nothing)


*EDIT* It may have been confusing, but I meant a solution. I already have an issue, so, sorry for any confusion that may have caused.

Edited: 09/10/2013 at 05:26 AM by fyre577
93172 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.