Topic Title: HD 6670 drivers need to be re-installed after every PC restart.
Topic Summary:
Created On: 09/16/2013 05:58 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/16/2013 05:58 PM
User is offline View Users Profile Print this message

Author Icon
theharddrinkingAJ
Peon

Posts: 5
Joined: 09/16/2013

I got my graphics card last christmas and encountered a few issues. Mainly preformance ones, I installed the latest drivers and it worked. Then when I shut off my PC and turned it on the next day it was weird again, I reinstall the drivers and everything is fine once more. So basically I need to reinstall the lastest driver using the set up tool after every computer restart. If I fail to I get unstable frame rate and ridiculously long load times.

The reason I never did anything is because the set up was fairly fast and didn't matter much to me but with the recent beta drivers it takes about 15 minutes to install them... I tried going back to the old drivers but it won't work with it anymore for some reason.

I don't know what the product number is, looking at the box I see part number so I'll assume that's the product number. it's 90-C1CQR5-L0UAY0YZ

 09/16/2013 06:56 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

It is just a ASUS 6670 card, but need more information detail in the Sticky Read Before Posting found at the top of these forum.

I will be back and forth in the forum, or maybe someone else will give you a hand once you supply the required information.

Just a hint you will need to go to the Control panel to remove the CCC. You may even have to use the device manager after that to remove the graphics driver. This will cause you to use Windows default driver. Then install the selected CCC package.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/16/2013 07:43 PM
User is offline View Users Profile Print this message

Author Icon
theharddrinkingAJ
Peon

Posts: 5
Joined: 09/16/2013

Oh, I thought I only had to put the information pertaining to my specific information. My bad.

The problem with that is I have no clue what most of my parts are, I just bought a stock PC and forget all the parts it came with.

 09/16/2013 08:02 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Well I believe you can indicate what is your O/S, what brand of cpu, amount of ram. The most of this you can get from the Properties of your Computer or Device Manager.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/16/2013 08:20 PM
User is offline View Users Profile Print this message

Author Icon
theharddrinkingAJ
Peon

Posts: 5
Joined: 09/16/2013

Well if that's all you need then I can definitly give you that info. Stuff like my motherboard I have no clue.

I have 6 GB DDR3 Ram

AMD athlon II X4 645

Windows 7 home premium 64 bit

 09/16/2013 08:27 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

What version of .Netframework do you have installed ?

It is a requirement that you have .Net 4.5 installed before trying to install the newer CCC. If you don't have it please install .Net 4.5, after you un-install the current CCC through the Control Panel. After you reboot then install the newer version of CCC 13.4.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/16/2013 09:50 PM
User is offline View Users Profile Print this message

Author Icon
theharddrinkingAJ
Peon

Posts: 5
Joined: 09/16/2013

I actually seem to be encountering an issue with uninstalling CCC. I don't seem to be able to find it in the remove programs list, I only see a catalyst installation program.

 09/16/2013 09:55 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

One in the same, that is the one you want to un-install. Be sure to select all AMD software.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/18/2013 03:20 PM
User is offline View Users Profile Print this message

Author Icon
theharddrinkingAJ
Peon

Posts: 5
Joined: 09/16/2013

I did as you said, uninstalled everything, rebooted, reinstalled it all and it still has the issue.

Statistics
84167 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.