Topic Title: 7790 Problems with 13.9 WHQL
Topic Summary:
Created On: 09/24/2013 03:29 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/24/2013 03:29 AM
User is offline View Users Profile Print this message

Author Icon
Ancalagon44
Peon

Posts: 3
Joined: 09/24/2013

Hi everyone,

I'm having trouble with every AMD driver except for the specific 13.4 7790 driver. And even that is not working 100% in all situations. First, specs:

AMD Phenom II X6 1055T - not overclocked at the moment

Asus M4A77TD Pro

4 x 2GB DDR3 1600

1 x OCZ Agility 3 240GB SSD

1 x WD Caviar Green 2TB

Corsair VX450 PSU

PowerColor 7790 TurboDuo 1GB

Win 7 64bit

Problems with 13.4:

Games work fine, but Firefox seems to encounter graphical corruption. On some pages, but not all, small black rectangular boxes appear on about 10% of the page. Moving the mouse over the boxes clears them, although they can reappear. Also sometimes the display driver crashes and recovers - never in games though.

Problems with 13.9 WHQL:

Often blue screens during installation of the driver. If installation succeeds, on rebooting I am told that no compatible AMD device could be found, and the display reverts to non-Aero. Very unstable. Did not get as far as testing games, since no videos work (not even youtube using the flash plugin) and neither does Aero.

Any suggestions? Could it be a hardware fault?

 09/24/2013 08:36 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7069
Joined: 11/13/2009

Minimum power requirements for that card is 500watt.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 09/24/2013 08:39 AM
User is offline View Users Profile Print this message

Author Icon
Ancalagon44
Peon

Posts: 3
Joined: 09/24/2013

Why would the different driver versions perform so differently? And why I not get instability issues when playing games, which obviously use the most power?

I had a 5770 for close on 3 years before upgrading - a 5770 actually draws more power anyway.

Its not the PSU.

 09/24/2013 08:52 AM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12246
Joined: 04/17/2008

I assume you also tested drivers previous to 13.4?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 09/24/2013 08:53 AM
User is offline View Users Profile Print this message

Author Icon
Ancalagon44
Peon

Posts: 3
Joined: 09/24/2013

No, I thought 13.4 was the earliest version to support the 7790?

 09/24/2013 05:27 PM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12246
Joined: 04/17/2008

The drivers which came on the disk with the card.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
Statistics
84297 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.