Topic Title: Battlefield 4 problem
Topic Summary:
Created On: 10/04/2013 03:43 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/04/2013 03:43 PM
User is offline View Users Profile Print this message

Author Icon
lukass_cze
Peon

Posts: 3
Joined: 10/04/2013

Hello,

I need help with a problem with the graphics card. When I want to connect to the server from BATTLELOG, I will table that I have an outdated driver. Unfortunately, I never found a version 13.4 for my graphics card (ATI Radeon HD 4650), which would be in accordance with the requirements of BF4 start .... Could you help me?

EDIT: then I will have this

http://s18.postimg.org/wpd1u639l/Abstract.jpg [s18.postimg.org]

Excuse my English

 10/04/2013 04:16 PM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7079
Joined: 11/13/2009

You have a 4000 series card. Get the drivers here>

http://support.amd.com/us/gpudownload/Pages/index.aspx



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 10/04/2013 04:26 PM
User is offline View Users Profile Print this message

Author Icon
lukass_cze
Peon

Posts: 3
Joined: 10/04/2013

I installed, but I still appearing in the Catalyst that I have version 13.1

 10/04/2013 05:09 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

The 13.4 drivers for 4000 series is a beta you need to scroll down the page. It is found below the download for 13.1.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 10/04/2013 05:16 PM
User is offline View Users Profile Print this message

Author Icon
lukass_cze
Peon

Posts: 3
Joined: 10/04/2013

I know it... I downloaded but it still doesnt work....

 10/04/2013 10:50 PM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 719
Joined: 08/28/2012

Did you uninstall your old driver before installing the new one?



-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

 10/04/2013 11:18 PM
User is offline View Users Profile Print this message

Author Icon
bigcountry055
Peon

Posts: 1
Joined: 10/04/2013

im haveing the same problem uninstalled  and installed 13.4 and says that its still at 13.1 and need up update to 13.4 please get to me asap 

 10/05/2013 12:26 AM
User is online View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7079
Joined: 11/13/2009

The FAQ section has a post "Installing/uninstalling Drivers"...

http://forums.amd.com/game/categories.cfm?catid=444&flcache=3017596&entercat=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84321 users are registered to the AMD Support and Game forum.
There are currently 11 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.