Topic Title: ATI HD 5850 Flickering in Windows/2D
Topic Summary: constant flickering, Default / OC doesn't matter.
Created On: 10/10/2013 05:34 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/10/2013 05:34 PM
User is offline View Users Profile Print this message

Author Icon
wonderboy1
Peon

Posts: 2
Joined: 10/10/2013

Hello,

I have a Sapphire ATI HD 5850. my screen keeps flickering as seen in the video below. the screen itself is ok and tested on another pc.

http://www.youtube.com/watch?v=KpQIvTzfRoM

Every couple of minutes, while in windows mostly, the image begins flickering. All drivers are up to date (I even tried the beta drivers, same results). 

After an extensive research I tried to overclock the card's Idle clock speeds (as some people claimed are too low due to power savings mode), no help there, same result - flickering.

Physically speaking, the card is in good shape, clean, works fine and doesn't overheat.

The ONLY thing that made ANY difference strangly enough is changing to a lower screen resolution, but I dont really know what to make of this finding.

Help me guys!

thanks,

 10/10/2013 05:41 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7823
Joined: 11/13/2009

Try using 'software' rendering instead of 'hardware' rendering. In IE goto tools/internet options/advanced. Same thing if using Firefox.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******

 10/10/2013 05:41 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 13068
Joined: 04/17/2008

If you are using a DVI cable, there are options to reduce DVI frequency on high resolution displays and an alternate DVI operation mode.

-------------------------
AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ultimate x64
 10/10/2013 05:50 PM
User is offline View Users Profile Print this message

Author Icon
wonderboy1
Peon

Posts: 2
Joined: 10/10/2013

Originally posted by: stumped Try using 'software' rendering instead of 'hardware' rendering. In IE goto tools/internet options/advanced. Same thing if using Firefox.

Thanks, but I don't use IE / Firefox. And this flickering happens regardles using a web browser or simply using windows.

Originally posted by: black_zion If you are using a DVI cable, there are options to reduce DVI frequency on high resolution displays and an alternate DVI operation mode.

Hey, I am actually using strange kind of cabel (the one that came with the screen form Samsung) - DVI connection on one end, and VGA connection on the other end.

Edit: I tried googling this DVI frequency settings option, as it apears, since I am using a VGA adaptor - I do not have any DVI options in CCC, it shows as a VGA cabel instead.



Edited: 10/10/2013 at 06:17 PM by wonderboy1
Statistics
88776 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.