Topic Title: Radeon HD 7570 issues
Topic Summary:
Created On: 10/12/2013 01:40 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/12/2013 01:40 PM
User is offline View Users Profile Print this message

Author Icon
jnsm
Peon

Posts: 1
Joined: 10/12/2013

Recently, all games I have tried running have been running at a much lower framerate than a week ago.  Previously, they had run at around 60+ on basically every game, using medium to high settings.  However, this has dropped to 30-45 fps.  Even when in-game settings are changed, the framerate is still very low.  I have tried messing around with the "AMD Overdrive" thing in CCC, but that has done nothing.  my specs are as follows:

 

Operating System

-Windows 8 64-bit

CPU

-Intel Core i7 4770 @ 3.40GHz

-Haswell 22nm Technology

RAM

-8.00GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)

Motherboard

-Dell Inc. 0KWVT8 (CPU 1)

Graphics

-DELL E2313H (1920x1080@60Hz)

-1024MB ATI AMD Radeon HD 7570 (Dell)

 

This is my first time posting here for support, so i apologise if i am vague or unclear with anything i post.  I have not downloaded anything that would affect the graphics card to cause this issue, and (as far as i know) this just started occurring out of nowhere.  Any help would be much appreciated!

 

 

Also, this card came with my pre-built desktop, the dell xps 8700 

http://www.dell.com/us/p/xps-8700/pd

 

Thanks!

Statistics
84673 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.