Topic Title: Recommended Drivers = Blackscreen on Windows Startup.
Topic Summary:
Created On: 10/13/2013 10:25 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/13/2013 10:25 PM
User is offline View Users Profile Print this message

Author Icon
alanthya
Peon

Posts: 5
Joined: 10/13/2013

I installed my Radeon 6970 after a bit of a battle, things we're running smooth until I decided to venture into the performance settings in AMD Catalyst. I had bumped the memory clock in 10 mhz increments up to 1450 if I recall correctly, and then set the power to +8. Things seemed to be running ok, I then restarted windows for another reason and half way through the windows startup screen, the monitor then turns off as if there is no video output. I'm assuming the bios on the card is screwed up now.

I have a spare 6950 lying around that is unlocked to a 6970. I uninstalled everything from the original 6970 setup, attached the unlocked card, run through the installation and have the same results on windows startup. Can anyone offer some help with this ugly situation? Thanks in advance.

 

Graphics Card
- Saphire Radeon 6970 HD

Operating System
- 32-bit Win7 SP1

Motherboard or System Make & Model
- ASROCK PV530A 1.8Ghz DualCore

Power Supply
- 550W

CPU Details
Embedded

Motherboard BIOS Version
- V1.0

System Memory Type & Amount
2GB Corsair DDR2

Additional Hardware
-SanDisk 32GB SSD



Edited: 10/16/2013 at 09:46 PM by alanthya
 10/13/2013 11:49 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Can you boot into safemode ? If so go into and turn off overdrive options or un-install the CCC package.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL



Edited: 10/14/2013 at 12:04 AM by WMudrockJr
 10/16/2013 10:24 AM
User is offline View Users Profile Print this message

Author Icon
alanthya
Peon

Posts: 5
Joined: 10/13/2013

I have tried several things and am still having issues with the cards. The first fix I tried was un-installing CCC through program manager. After un-installing I was able to boot up without losing display during windows startup. I then reinstalled  the latest drivers provided by AMD, the card will sucessfully install and request to restart the computer to apply the new settings. The computer will restart, show the boot screen and continue to the Starting Windows screen for a few seconds, then the display output turns off & the monitor begins searching for video input. This happens with both the 6950 (Unlocked to 6970) and the 6970 cards I have.

I managed to bypass the issue once by installing a fresh copy of Win7, the card installed and worked properly. I then had to restart the computer for other reasons, and ran into the same issue with the display blacking out on the Starting Window screen.

Did CCC modify the bios's in both the card's I connected? If so how can I revert them. Are there any alternative driver options that don't utilize Catalyst Control Center, and provide OpenCL support? Any help on this frusturating issue is much appreciated.

 10/16/2013 09:43 PM
User is offline View Users Profile Print this message

Author Icon
alanthya
Peon

Posts: 5
Joined: 10/13/2013

So I have narrowed the issue down to the actual video driver itself. Removed all existing AMD drivers with Driver Cleaner in safe mode, reboot and back to semi-normal with display working, device manager then shows driver issues on the card as expected. I then un-installed the card through device manager, restarted, let windows install the default vga drivers for the card, then stripped down the AMD Catalyst install package of everything but the video driver. Install, restart, bam black screen 5-8 seconds after windows starting screen. The driver I'm installing is the one recommended by AMD driver autodetect, are there any alternatives?

Statistics
84247 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.