Topic Title: radeon r9 280x issues
Topic Summary:
Created On: 10/26/2013 10:16 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/26/2013 10:16 AM
User is offline View Users Profile Print this message

Author Icon
dingers
Peon

Posts: 7
Joined: 10/26/2013

hi there,wondering if anyone can please help.bought a new radeon r9 280x card a few days ago and have many issues:-screen suddenly going pin stripped and crashing-games running on lowest graphics settings or not running at all due to various reasonsive downloaded the latest drivers for the card and it has the manufacturers recommended power 750w.amd fx 8150 8 core8gb ramany ideas as to resolve these issues?i was convinced to upgrade from nvidia to amd and am regretting doing so.

-------------------------
 10/26/2013 10:26 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7275
Joined: 11/13/2009

I would make sure all Nvidia software is deleted by using Driver Sweeper version 3.2 (do not upgrade it when asked)...select Nvidia graphics and delete all it finds. Then do a clean install of the AMD driver suite using the guide in the FAQ section.

http://www.techspot.com/downloads/4266-driver-sweeper.html



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 10/26/2013 11:16 AM
User is offline View Users Profile Print this message

Author Icon
dingers
Peon

Posts: 7
Joined: 10/26/2013

when i run the driver sweep 3 nvidia options appear. display, physx and chipset. do i delete them all?  thanks for your help

-------------------------
 10/26/2013 11:36 AM
User is offline View Users Profile Print this message

Author Icon
nutyboi
Peon

Posts: 10
Joined: 09/22/2010

Remove everything related to Nvidia. I too have a problem with my r9 290x. By any chance, is your gpu constantly at 100% usage?

I too have huge performance issues if the game actually starts running (usually they crash before even loading the startup screen).

Try remove all related Nvidia drivers with driver sweeper, restart, install amd drivers & pray.



-------------------------

Asus crosshair v-formula
AMD fx-8150
AMD Saphire R9 290x
2x Corsair Vengeance 4gb ddr3 @1600 (8 total)
OCZ Vertex 4 ssd - 256gb
silverstone sst-st85f-p (850w)
Samsung bx2350 & acer s240hl
Cooler Master HAF 932


 


 

 10/26/2013 12:00 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7275
Joined: 11/13/2009

Originally posted by: dingers when i run the driver sweep 3 nvidia options appear. display, physx and chipset. do i delete them all?  thanks for your help

I would select them all...just because the option is there doesn't mean you have them installed. After a reboot, follow the "Clean install" post, deleting any AMD drivers that you tried to install...reboot and install the new driver suite.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 10/26/2013 12:02 PM
User is offline View Users Profile Print this message

Author Icon
dingers
Peon

Posts: 7
Joined: 10/26/2013

removed every nvidia file with driver sweeper but still same problems. my gpu isnt at 100% no.epically annoyed. you would have thought that these companys would have software that does this for you so it truly is plug and play. only option left is a complete system wipe and reinstall or abandon radeon and return to nvidia.

-------------------------
 10/26/2013 12:04 PM
User is offline View Users Profile Print this message

Author Icon
dingers
Peon

Posts: 7
Joined: 10/26/2013

missed out "and reinstalled catalyst drivers"

-------------------------
Statistics
86426 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.